aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-16 15:41:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-16 15:46:37 +0000
commite8967a578e6947b154d98effc1caaac5f5425885 (patch)
tree4f57f41086a8d9845e47ac01d9d6b19620db1692 /community
parentdeb5d49a64cd0d92cc28e108513dd3494739e008 (diff)
downloadaports-e8967a578e6947b154d98effc1caaac5f5425885.tar.bz2
aports-e8967a578e6947b154d98effc1caaac5f5425885.tar.xz
community/libsearpc: move from main
Diffstat (limited to 'community')
-rw-r--r--community/libsearpc/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/libsearpc/APKBUILD b/community/libsearpc/APKBUILD
new file mode 100644
index 0000000000..ae29d8d7fd
--- /dev/null
+++ b/community/libsearpc/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsearpc
+pkgver=3.0.6
+pkgrel=0
+pkgdesc="A simple and easy-to-use C language RPC framework"
+url="https://github.com/haiwen/libsearpc/"
+arch="all"
+license="LGPL2.1"
+makedepends="autoconf automake bash glib-dev jansson-dev libtool python-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haiwen/libsearpc/archive/v3.0-latest.tar.gz"
+subpackages="$pkgname-dev py-$pkgname:py"
+
+_builddir="${srcdir}"/${pkgname}-3.0-latest
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+ rm "${pkgdir}"/usr/lib/libsearpc.la
+ echo ${pkgdir}/usr/lib/pkgconfig/libsearpc.pc
+ sed -i -e 's/(DESTDIR)//' "${pkgdir}"/usr/lib/pkgconfig/libsearpc.pc
+ sed -i -e 's/prefix=.*/prefix=\/usr/' "${pkgdir}"/usr/lib/pkgconfig/libsearpc.pc
+}
+
+py() {
+ arch="noarch"
+ cd "$_builddir"
+ pkgdesc="$pkgname python bindings"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+md5sums="32a6eaafe16d8c0c0e320b4a08a4d8f6 libsearpc-3.0.6.tar.gz"
+sha256sums="56313771e0ad7dc075c4590b6a75daeb3939937b21716d82c91be2612133b8cd libsearpc-3.0.6.tar.gz"
+sha512sums="f5706d5490eb6abd05a25963ae204b358e7ebdcf153ab4bfe76819fd4538f1a957d7eaf84d8e60e076d978f9c1605adb2e6ec7ded55950c551304eb7665b15e8 libsearpc-3.0.6.tar.gz"