aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-11-21 22:29:33 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-24 20:53:25 +0100
commitb5b5a5b646a24138f04841f9ee3fd341d34c8805 (patch)
treea4c118804830425e5b1c3d91f1af93f52a1ab7ec /community
parent038556d6447f40588f422f7c60935eca7afd6629 (diff)
downloadaports-b5b5a5b646a24138f04841f9ee3fd341d34c8805.tar.bz2
aports-b5b5a5b646a24138f04841f9ee3fd341d34c8805.tar.xz
community/geos: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/geos/10-configure-python3.patch35
-rw-r--r--community/geos/APKBUILD74
2 files changed, 109 insertions, 0 deletions
diff --git a/community/geos/10-configure-python3.patch b/community/geos/10-configure-python3.patch
new file mode 100644
index 0000000000..417d13d492
--- /dev/null
+++ b/community/geos/10-configure-python3.patch
@@ -0,0 +1,35 @@
+Author: Holger Jaekel <holger.jaekel@gmx.de>
+Summary: Patch configure script for python3
+----
+
+--- a/configure
++++ b/configure
+@@ -19209,8 +19209,9 @@ $as_echo "$python_path" >&6; }
+ # Check for Python library path
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for Python library path" >&5
+ $as_echo_n "checking for Python library path... " >&6; }
++ PYTHON_MAJOR=`echo $PYTHON_VERSION | cut -d. -f1`
+ for i in "$base_python_path/lib/python$PYTHON_VERSION/config/" "$base_python_path/lib/python$PYTHON_VERSION/" "$base_python_path/lib/python/config/" "$base_python_path/lib/python/" "$base_python_path/" "$base_python_path/libs/" ; do
+- python_path=`find $i -name libpython$PYTHON_VERSION.* -print 2> /dev/null | sed "1q"`
++ python_path=`find $i -name libpython$PYTHON_MAJOR.* -print 2> /dev/null | sed "1q"`
+ if test -n "$python_path" ; then
+ break
+ fi
+@@ -19221,7 +19222,7 @@ $as_echo "$python_path" >&6; }
+ if test -z "$python_path" ; then
+ as_fn_error $? "cannot find Python library path" "$LINENO" 5
+ fi
+- PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_VERSION"
++ PYTHON_LDFLAGS="-L$python_path -lpython$PYTHON_MAJOR"
+
+ #
+ python_site=`echo $base_python_path | sed "s/config/site-packages/"`
+@@ -19234,7 +19235,7 @@ $as_echo "$python_path" >&6; }
+ $as_echo_n "checking python extra libraries... " >&6; }
+ PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
+ conf = distutils.sysconfig.get_config_var; \
+- print (conf('LOCALMODLIBS') or '')+' '+(conf('LIBS') or '')"
++ print ((conf('LOCALMODLIBS') or '')+' '+(conf('LIBS') or ''))"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHON_EXTRA_LIBS" >&5
+ $as_echo "$PYTHON_EXTRA_LIBS" >&6; }`
+
diff --git a/community/geos/APKBUILD b/community/geos/APKBUILD
new file mode 100644
index 0000000000..69a85b1797
--- /dev/null
+++ b/community/geos/APKBUILD
@@ -0,0 +1,74 @@
+# Contributor: Eric Kidd <git@randomhacks.net>
+# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
+pkgname=geos
+pkgver=3.8.0
+pkgrel=0
+pkgdesc="GEOS is a library providing OpenGIS and JTS spatial operations in C++."
+url="https://trac.osgeo.org/geos/"
+arch="all !s390x"
+license="LGPL-2.1-or-later"
+makedepends="
+ swig
+ python3-dev
+ ruby-dev
+ "
+subpackages="
+ py3-$pkgname:py3
+ ruby-$pkgname:ruby
+ $pkgname-dev
+ "
+source="
+ http://download.osgeo.org/geos/geos-$pkgver.tar.bz2
+ 10-configure-python3.patch
+ "
+
+build() {
+ case "$CARCH" in
+ aarch64*|ppc64le) CXXFLAGS="$CXXFLAGS -ffp-contract=off" ;;
+ esac
+
+ # fix build on armhf and armv7 with info from
+ # https://trac.osgeo.org/geos/ticket/993
+ local inline="--enable-inline"
+ case "$CARCH" in
+ armhf|armv7) inline="--disable-inline" ;;
+ esac
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ $inline \
+ --enable-python \
+ --enable-ruby
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find $pkgdir -name "*.a" -type f -delete
+}
+
+py3() {
+ pkgdesc="$pkgname Python3 bindings"
+
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+ruby() {
+ pkgdesc="$pkgname Ruby bindings"
+
+ install -d "$subpkgdir"/usr/lib/ruby/vendor_ruby
+ mv "$pkgdir"/usr/local/lib/site_ruby/* "$subpkgdir"/usr/lib/ruby/vendor_ruby
+ rm -rf "${pkgdir:?}"/usr/local
+}
+sha512sums="c89b25b42092152ef261090f25ff64b229f30f67d42fdf44c2871e78b66bb2c42e23b9ae21f9aea0e48823bdb0267d609ab2ee77d310abcb76fa672c6614d8f1 geos-3.8.0.tar.bz2
+a76aceadb30c6a078ef9c671d8335647bd6b94094bd4bdda5958f0d50271552e8f1f7b4e9d4295986f4371a446071c3cc3a446ef520543e820bde83833fea18e 10-configure-python3.patch"