aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-22 09:47:37 +0300
committerprspkt <prspkt@protonmail.com>2019-08-22 09:50:13 +0300
commit9d9bda7cee1a0fdfe9a466be6948b00c9dc45396 (patch)
tree9d7232712ac4f143d7d56b9508948bc9d13c0e8e /community
parentde93401a27268f2ca66af5ccf472ea8efa10029f (diff)
downloadaports-9d9bda7cee1a0fdfe9a466be6948b00c9dc45396.tar.bz2
aports-9d9bda7cee1a0fdfe9a466be6948b00c9dc45396.tar.xz
community/py-augeas: clarify license
* Fix runtime dependencies. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community')
-rw-r--r--community/py-augeas/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/py-augeas/APKBUILD b/community/py-augeas/APKBUILD
index f8bd9bc5a1..1885d7c562 100644
--- a/community/py-augeas/APKBUILD
+++ b/community/py-augeas/APKBUILD
@@ -3,13 +3,13 @@
pkgname=py-augeas
_pkgname=python-augeas
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="Pure python bindings for augeas"
url="https://pypi.python.org/pypi/python-augeas"
arch="noarch"
-license="GPL-2.1"
+license="LGPL-2.1-or-later"
depends="augeas-libs py-cffi"
-makedepends="python2-dev python3-dev py-setuptools"
+makedepends="py2-setuptools py3-setuptools"
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
dlopen-libc-explicitly.patch
@@ -18,9 +18,8 @@ source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
check() {
@@ -34,7 +33,7 @@ package() {
}
_py() {
- local python=$1
+ local python="$1"
pkgdesc="$pkgdesc - $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
@@ -42,11 +41,14 @@ _py() {
}
_py2() {
+ depends="${depends//py-/py2-}"
_py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
}
+
sha512sums="737b41e7bb438d80da75b55714c3f0b1706a4b2cacddd20fadf855bc3044e532f4079319b3775032e6f6009cf7f282af33fdf583332772b443a6c2d4925639fa python-augeas-1.0.3.tar.gz
938e1a28d70c8ffbf62fd2936a57276603487608fbb3e23bf3a59a4f655e7d875ad51e6506acbddf4eea27a433fe3c9c35da3e00be04c8c866a5a966cdf3b161 dlopen-libc-explicitly.patch"