aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-24 23:52:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-24 23:54:32 +0200
commit15074a08cdd46a9fd6b03833fa482878bd2c7475 (patch)
tree83943d20b3ee741012041a18a82cd5c9afa98284 /community
parent0ef7aaf539dabc484c407800aa7c19789adb54c8 (diff)
downloadaports-15074a08cdd46a9fd6b03833fa482878bd2c7475.tar.bz2
aports-15074a08cdd46a9fd6b03833fa482878bd2c7475.tar.xz
community/lua-rapidjson: upgrade to 0.5.1
Diffstat (limited to 'community')
-rw-r--r--community/lua-rapidjson/APKBUILD12
-rw-r--r--community/lua-rapidjson/fix-json_encode_spec.patch13
2 files changed, 20 insertions, 5 deletions
diff --git a/community/lua-rapidjson/APKBUILD b/community/lua-rapidjson/APKBUILD
index fd02208f3d..b721badb88 100644
--- a/community/lua-rapidjson/APKBUILD
+++ b/community/lua-rapidjson/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-rapidjson
-pkgver=0.5.0
-pkgrel=3
+pkgver=0.5.1
+pkgrel=0
pkgdesc="A JSON module for Lua based on the very fast RapidJSON library"
url="https://github.com/xpol/lua-rapidjson"
arch="all"
@@ -11,7 +11,8 @@ makedepends="cmake rapidjson-dev"
subpackages=""
checkdepends="lua-busted lua-dromozoa-utf8"
source="$pkgname-$pkgver.tar.gz::https://github.com/xpol/$pkgname/archive/v$pkgver.tar.gz
- disable-c-cxx-flag-march.patch"
+ disable-c-cxx-flag-march.patch
+ fix-json_encode_spec.patch"
builddir="$srcdir/$pkgname-$pkgver"
# luajit is not available for selected arches
@@ -79,5 +80,6 @@ _subpackage() {
"$subpkgdir"/$install_cmod/rapidjson.so
}
-sha512sums="eb07792d01d6bf32d2ccec244fd5f55ce3e66b356b8e61f0dd86b7e6c4a5a582ab8cb64e2af1f79628e85409e60bf2edd05e2bff12be4987650d948baf246ef3 lua-rapidjson-0.5.0.tar.gz
-9bfe86c75765d0684f33b660129c3ab90629b8518b05d14aa99ea15e6eb39dcb0a56e9a705f2dcae0f463e7ed92c8759628b0fbdaeee43aff34ac7e5b6c6bf10 disable-c-cxx-flag-march.patch"
+sha512sums="281a7f98212d1648f270180a2f7475884c5cb9c9b1ee901113fc2a96bff86b4897c8d9cc0e40f7cf1b9edd09540119734118f7e06879eaaecf3f3d6f7f5f84e0 lua-rapidjson-0.5.1.tar.gz
+9bfe86c75765d0684f33b660129c3ab90629b8518b05d14aa99ea15e6eb39dcb0a56e9a705f2dcae0f463e7ed92c8759628b0fbdaeee43aff34ac7e5b6c6bf10 disable-c-cxx-flag-march.patch
+ad66d29f6dd1ed1a3eafff79b77567a28c0b5d746a2564e0ce5fa8a26bf792d788b96ec63bacd907f85c89a561ada690c526e6be36246cd50f8ea45180977cc0 fix-json_encode_spec.patch"
diff --git a/community/lua-rapidjson/fix-json_encode_spec.patch b/community/lua-rapidjson/fix-json_encode_spec.patch
new file mode 100644
index 0000000000..e2cf38078e
--- /dev/null
+++ b/community/lua-rapidjson/fix-json_encode_spec.patch
@@ -0,0 +1,13 @@
+--- a/spec/json_encode_spec.lua
++++ b/spec/json_encode_spec.lua
+@@ -131,8 +131,8 @@
+ end)
+
+ it('should support empty_table_as_array options', function()
+- assert.are.equal('{"a": []}', rapidjson.encode({a={}}, {empty_table_as_array=true}))
+- assert.are.equal('{"a": {}}', rapidjson.encode({a={}}))
++ assert.are.equal('{"a":[]}', rapidjson.encode({a={}}, {empty_table_as_array=true}))
++ assert.are.equal('{"a":{}}', rapidjson.encode({a={}}))
+ end)
+ it('should support sort_keys and pretty options', function()
+ assert.are.equal(