aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-24 18:12:10 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-24 15:01:49 -0300
commit6899cc199bb2df2b1823bb804edb69c1b3471c10 (patch)
tree0971d95aef5ca5db469543cbef24891f5e001319 /community
parenta14132ff16af5d44fe9820853843faabf50d9bb6 (diff)
downloadaports-6899cc199bb2df2b1823bb804edb69c1b3471c10.tar.bz2
aports-6899cc199bb2df2b1823bb804edb69c1b3471c10.tar.xz
community/linuxconsoletools: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/linuxconsoletools/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/linuxconsoletools/APKBUILD b/community/linuxconsoletools/APKBUILD
new file mode 100644
index 0000000000..ff19b7eec1
--- /dev/null
+++ b/community/linuxconsoletools/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=linuxconsoletools
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Tools for connecting joysticks & legacy devices to the kernels input subsystem"
+url="https://sourceforge.net/projects/linuxconsole/"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="linux-headers sdl2-dev"
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/linuxconsole/linuxconsoletools-$pkgver.tar.bz2"
+
+
+build() {
+ make PREFIX=/usr
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="260667e167281dd6f4de0904c2852a5bf3d9d0fe9d603135d4849c5a6610997306c9b476f64e4015d17a4dc8e4a8d36e96e01b9b63664fc7b493201fe12b4f56 linuxconsoletools-1.7.0.tar.bz2"