aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-01 15:33:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-01 15:33:38 -0300
commit6cbfe6594c7992496811a16cd64f63851e5b36cd (patch)
tree107840a19cd3f86e9b4590ec12d1da6f483694fb /community
parenta10dc481a79a0b2cd050d89972b0d352e003f9c5 (diff)
downloadaports-6cbfe6594c7992496811a16cd64f63851e5b36cd.tar.bz2
aports-6cbfe6594c7992496811a16cd64f63851e5b36cd.tar.xz
community/flatbuffers: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/flatbuffers/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/flatbuffers/APKBUILD b/community/flatbuffers/APKBUILD
new file mode 100644
index 0000000000..ef0d9a19b4
--- /dev/null
+++ b/community/flatbuffers/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=flatbuffers
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="Memory Efficient Serialization Library"
+url="https://google.github.io/flatbuffers/"
+arch="all !s390x"
+license="Apache-2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-dev"
+source="flatbuffers-$pkgver.tar.gz::https://github.com/google/flatbuffers/archive/v$pkgver.tar.gz"
+builddir="$srcdir/flatbuffers-$pkgver"
+
+build() {
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DFLATBUFFERS_BUILD_SHAREDLIB=on \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ make test
+}
+
+package() {
+ cd "$builddir"/build
+ make install DESTDIR="$pkgdir"
+ install -Dm755 "$builddir"/build/flatc \
+ "$pkgdir"/usr/bin/flatc
+}
+
+sha512sums="b8382c8e9a45d6aca83270e93704b9ef2938e4ef9bb5165edbd8f286329e86353037ad6e54a99fd3d70b0c893d06cfd8766e00f05497e69be4b9e6c0506133d2 flatbuffers-1.10.0.tar.gz"