aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNero <41307858+nero@users.noreply.github.com>2020-01-29 18:31:42 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-01-30 19:41:08 +0100
commit6fa92d803d52c96419054c0b62d0644e25c863f0 (patch)
tree09ebde379c2ceb27eab20f5c4584011e901b9e14 /community
parent127dd698f19a77a7ddc5be9eab815aa415fa4045 (diff)
downloadaports-6fa92d803d52c96419054c0b62d0644e25c863f0.tar.bz2
aports-6fa92d803d52c96419054c0b62d0644e25c863f0.tar.xz
community/babl: upgrade to 0.1.72
Upstream now ships xz-compressed tarballs, the makefile was replaced by meson.
Diffstat (limited to 'community')
-rw-r--r--community/babl/APKBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/community/babl/APKBUILD b/community/babl/APKBUILD
index 2f31d63591..5fd9f2b979 100644
--- a/community/babl/APKBUILD
+++ b/community/babl/APKBUILD
@@ -1,31 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=babl
-pkgver=0.1.66
+pkgver=0.1.72
pkgrel=0
pkgdesc="Dynamic, any to any, pixel format conversion library"
url="http://gegl.org/babl"
arch="all"
license="LGPL-3.0-or-later"
+makedepends="meson gobject-introspection-dev lcms2-dev"
subpackages="$pkgname-dev"
-source="https://ftp.gimp.org/pub/babl/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+source="https://ftp.gimp.org/pub/babl/${pkgver%.*}/babl-$pkgver.tar.xz"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr
- make
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
}
check() {
- cd "$builddir"
- make check
+ ninja -C output test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="41534eea6cad21eae704af3fdce4857e9dc2b0efa48a7cfd7f98b23428198e95fc9ca2f30e522abf2fa06e907eaf4f7bbafc048b356cb5890fabcb9be21001b3 babl-0.1.66.tar.bz2"
+sha512sums="55425688467d565acecbe3657ed4191971fe70d0da0f69c348eec8a6db9807f3e27f5101cade2d886d017b5156e4ef56382df93f26cc335acb4ce33bbef23d6b babl-0.1.72.tar.xz"