aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-26 19:55:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-09 08:03:07 -0300
commit7b9912516f89918744ad9654a76e971c26bf0a21 (patch)
tree7c34e22750e11c72ab0f4fbbd9b1d3472d3269f6 /community
parent3a16ad58222e2b9aa9e9e8007e8a3f15f49d2be3 (diff)
downloadaports-7b9912516f89918744ad9654a76e971c26bf0a21.tar.bz2
aports-7b9912516f89918744ad9654a76e971c26bf0a21.tar.xz
community/py3-django-filter: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-django-filter/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-django-filter/APKBUILD b/community/py3-django-filter/APKBUILD
new file mode 100644
index 0000000000..90a38f48fd
--- /dev/null
+++ b/community/py3-django-filter/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py3-django-filter
+_pkgname=django-filter
+pkgver=2.0.0
+pkgrel=2
+pkgdesc="Generic system for filtering Django QuerySets based on user selections"
+url="https://github.com/carltongibson/django-filter"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-django"
+makedepends="py3-setuptools"
+checkdepends="py3-markdown py3-core-api py3-coverage py3-tz
+ py3-django-crispy-forms py3-django-rest-framework py3-mock"
+source="$pkgname-$pkgver.tar.gz::https://github.com/carltongibson/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py --quiet build
+}
+
+check() {
+ python3 runtests.py
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+}
+
+
+sha512sums="48a2741e1f15eb756cdba7575943401fc211b398cf91d40cad4159d44fbd2303449bddc7cd791bf7857506bc98a4e9ff2143ed29781b9a884b2d6f35cceaf4a0 py3-django-filter-2.0.0.tar.gz"