aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-02-25 23:41:01 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-02-27 00:03:25 +0000
commit840b395804eefe12b46298dc1f8557e61e108263 (patch)
tree3f88b822ca0784b724cfbbecd1792151cb937122 /community
parentbc8ce1783e53e945f2d1400ce1e6edcc28b88ff8 (diff)
downloadaports-840b395804eefe12b46298dc1f8557e61e108263.tar.bz2
aports-840b395804eefe12b46298dc1f8557e61e108263.tar.xz
community/perl-crypt-passwdmd5: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/perl-crypt-passwdmd5/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/perl-crypt-passwdmd5/APKBUILD b/community/perl-crypt-passwdmd5/APKBUILD
new file mode 100644
index 0000000000..36f0302284
--- /dev/null
+++ b/community/perl-crypt-passwdmd5/APKBUILD
@@ -0,0 +1,32 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-crypt-passwdmd5
+_pkgreal=Crypt-PasswdMD5
+pkgver=1.40
+pkgrel=1
+pkgdesc="Provide interoperable MD5-based crypt() functions"
+url="https://metacpan.org/release/Crypt-PasswdMD5/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/R/RS/RSAVAGE/Crypt-PasswdMD5-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="c00f76210a9c07ad610b4698b15d142c3859100a13af620919e32bf046ab2febf8ebedafcffa4dde62f7e9af0e9ff137dae623e0bab60380fca003f7b35bfc77 Crypt-PasswdMD5-1.40.tgz"