aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2019-07-03 21:32:54 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 03:30:57 -0300
commit8ac3d7a2d8987fdb4093b1becc2d3a5ead17cb02 (patch)
treed46740477304f60beba1871c585ed738a573752c /community
parentb331d273c00c040b4ddd764650d3d4b04a6c0482 (diff)
downloadaports-8ac3d7a2d8987fdb4093b1becc2d3a5ead17cb02.tar.bz2
aports-8ac3d7a2d8987fdb4093b1becc2d3a5ead17cb02.tar.xz
community/py-opencl: upgrade to 2019.1
Diffstat (limited to 'community')
-rw-r--r--community/py-opencl/APKBUILD10
-rw-r--r--community/py-opencl/fix-compiler-choice.patch25
2 files changed, 4 insertions, 31 deletions
diff --git a/community/py-opencl/APKBUILD b/community/py-opencl/APKBUILD
index e31605ed1d..da6f69dc9f 100644
--- a/community/py-opencl/APKBUILD
+++ b/community/py-opencl/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=py-opencl
_pkgreal=${pkgname/-/}
-pkgver=2018.2.5
-pkgrel=1
+pkgver=2019.1
+pkgrel=0
pkgdesc="Python wrapper for OpenCL"
url="https://pypi.python.org/pypi/pyopencl"
arch="all"
@@ -14,8 +14,7 @@ makedepends="python2-dev python3-dev py-setuptools py-numpy>=1.14.3-r1 ctags
py-pybind11 py-numpy-dev"
checkdepends="py-six py-decorator pytest py-py"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz
- fix-compiler-choice.patch"
+source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
options="!check" # tests require python-theano which isn't packed yet
@@ -53,5 +52,4 @@ check() {
python2 setup.py test
}
-sha512sums="91f9e9b15ef0dbf22440b6abf762c729e8de587966c9d9a5da8c7ac02230ef700e31056248f1d93ec7e7af6e79918d68e18139e413f3cef287ecf683ee81ac05 pyopencl-2018.2.5.tar.gz
-b6d1295f2b413d3b27a13632df1bc7b9390423622c5748bd0d929555797ee63fd9f217b132a005a3b082d9e96952115c7846eeb675e23f69d6aeea8aa57af5e1 fix-compiler-choice.patch"
+sha512sums="6a808799a4c065371ce41cc71fc5386ba5462e2a6b908f06f6062afe9c7b05d262fa13314398ba2effd83ed196871c7b2d0695d496c43b8217b33f2c43bba096 pyopencl-2019.1.tar.gz"
diff --git a/community/py-opencl/fix-compiler-choice.patch b/community/py-opencl/fix-compiler-choice.patch
deleted file mode 100644
index 1de460e9cc..0000000000
--- a/community/py-opencl/fix-compiler-choice.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 2dd4a31f03c2fbf7504dca64a9f66c63fc37f018 Mon Sep 17 00:00:00 2001
-From: Andreas Kloeckner <inform@tiker.net>
-Date: Fri, 3 May 2019 17:58:49 -0500
-Subject: [PATCH] Try -std=gnu++14 before c++14
- (https://github.com/inducer/pyopencl/issues/280)
-
----
- aksetup_helper.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/aksetup_helper.py b/aksetup_helper.py
-index e86f4cd..f90d085 100644
---- a/aksetup_helper.py
-+++ b/aksetup_helper.py
-@@ -917,7 +917,9 @@ def cpp_flag(compiler):
-
- The c++14 is prefered over c++11 (when it is available).
- """
-- if has_flag(compiler, '-std=c++14'):
-+ if has_flag(compiler, '-std=gnu++14'):
-+ return '-std=gnu++14'
-+ elif has_flag(compiler, '-std=c++14'):
- return '-std=c++14'
- elif has_flag(compiler, '-std=c++11'):
- return '-std=c++11'