aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-03-17 12:02:40 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-03-17 12:02:40 +0100
commita26d70ac45cacbc9099848d926e45185e4ad1e22 (patch)
treec6211fa2e9d04d36ab47fe0f54e078d211930a58 /community
parent3bbd1c00d66e582a721a4ead9b10b7b3cd40b082 (diff)
downloadaports-a26d70ac45cacbc9099848d926e45185e4ad1e22.tar.bz2
aports-a26d70ac45cacbc9099848d926e45185e4ad1e22.tar.xz
community/chicken: modernize APKBUILD
Diffstat (limited to 'community')
-rw-r--r--community/chicken/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/community/chicken/APKBUILD b/community/chicken/APKBUILD
index d3f1154fe7..ef29f062f0 100644
--- a/community/chicken/APKBUILD
+++ b/community/chicken/APKBUILD
@@ -11,7 +11,6 @@ license="BSD-3-Clause"
depends="gcc libc-dev $pkgname-dev $pkgname-libs"
subpackages="$pkgname-doc $pkgname-libs $pkgname-dev $pkgname-feathers::noarch"
source="https://code.call-cc.org/releases/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
# 4.12.0-r3:
@@ -24,19 +23,16 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
# chicken does not support parallel builds.
- make -j1 PLATFORM=linux PREFIX=/usr \
- -C "$builddir"
+ make -j1 PLATFORM=linux PREFIX=/usr
}
check() {
- make -j1 PLATFORM=linux \
- -C "$builddir" check
+ make -j1 PLATFORM=linux check
}
package() {
# chicken does not support parallel installs.
- make -j1 PLATFORM=linux PREFIX=/usr DESTDIR="$pkgdir" \
- -C "$builddir" install
+ make -j1 PLATFORM=linux PREFIX=/usr DESTDIR="$pkgdir" install
# Move documentation to /usr/share/doc.
mkdir -p "$pkgdir"/usr/share/doc/