aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorEric Molitor <eric@molitor.org>2019-01-13 11:09:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-22 12:12:49 +0000
commita84ab695096337553ae79182143730853331e0e5 (patch)
tree1d9bdd2785fc4ca7b527d157df5801acdec0c4f1 /community
parent09ed5f798886f450d1c66f0af50111e54e3c8870 (diff)
downloadaports-a84ab695096337553ae79182143730853331e0e5.tar.bz2
aports-a84ab695096337553ae79182143730853331e0e5.tar.xz
community/lld: upgrade to 7.0.1
Diffstat (limited to 'community')
-rw-r--r--community/lld/APKBUILD14
-rw-r--r--community/lld/cmake-fix-pthread-handling-for-out-of-tree-builds.patch80
2 files changed, 9 insertions, 85 deletions
diff --git a/community/lld/APKBUILD b/community/lld/APKBUILD
index 65f32d3cf4..640003d80b 100644
--- a/community/lld/APKBUILD
+++ b/community/lld/APKBUILD
@@ -1,7 +1,8 @@
+# Contributor: Eric Molitor <eric@molitor.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lld
-pkgver=5.0.2
+pkgver=7.0.1
pkgrel=0
_llvmver=${pkgver%%.*}
pkgdesc="The LLVM Linker"
@@ -17,7 +18,7 @@ makedepends="
zlib-dev"
checkdepends="gtest gtest-dev"
subpackages="$pkgname-dev"
-source="https://releases.llvm.org/$pkgver/$pkgname-$pkgver.src.tar.xz"
+source="https://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.xz"
builddir="$srcdir/$pkgname-$pkgver.src"
build() {
@@ -31,7 +32,6 @@ build() {
-DCMAKE_CXX_FLAGS_MINSIZEREL_INIT="$CXXFLAGS -fpermissive" \
-DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
-DLLVM_INCLUDE_TESTS=ON
make
@@ -40,7 +40,11 @@ build() {
check() {
cd "$builddir/build"
[ "$CARCH" = "armhf" ] && return 0
- make check-lld
+ #make check-lld
+ lit -sv \
+ --param lld_site_config=$builddir/build/test/lit.site.cfg \
+ --param lld_unit_site_config=$builddir/build/test/Unit/lit.site.cfg \
+ $builddir/build/test
}
package() {
@@ -49,4 +53,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="6edafc277a5475a4b44fdf2d77bb8d0a80e8717f74c6db6c0208e0f1492a552f50640503ba8687bcd87a3d677b571dc4f9579b1e5c0bf53059c259ecbcc78c0e lld-5.0.2.src.tar.xz"
+sha512sums="e5d3ed280d8ac6014cd6bbe080b11e2c4ebbae81dc14b637e779ec027d818dbae91c6f0de9e94bcecd6bdaa37f12c35141b5d81f0a15251d27932aa9bebd4047 lld-7.0.1.src.tar.xz"
diff --git a/community/lld/cmake-fix-pthread-handling-for-out-of-tree-builds.patch b/community/lld/cmake-fix-pthread-handling-for-out-of-tree-builds.patch
deleted file mode 100644
index b2a66f1a13..0000000000
--- a/community/lld/cmake-fix-pthread-handling-for-out-of-tree-builds.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 548cd5eb4f45de4ec71b3421a98c9462aed75c91 Mon Sep 17 00:00:00 2001
-From: Eric Fiselier <eric@efcs.ca>
-Date: Fri, 10 Feb 2017 01:59:20 +0000
-Subject: [PATCH] [CMake] Fix pthread handling for out-of-tree builds
-
-LLVM defines `PTHREAD_LIB` which is used by AddLLVM.cmake and various projects
-to correctly link the threading library when needed. Unfortunately
-`PTHREAD_LIB` is defined by LLVM's `config-ix.cmake` file which isn't installed
-and therefore can't be used when configuring out-of-tree builds. This causes
-such builds to fail since `pthread` isn't being correctly linked.
-
-This patch attempts to fix that problem by renaming and exporting
-`LLVM_PTHREAD_LIB` as part of`LLVMConfig.cmake`. I renamed `PTHREAD_LIB`
-because It seemed likely to cause collisions with downstream users of
-`LLVMConfig.cmake`.
-
-
-git-svn-id: https://llvm.org/svn/llvm-project/lld/trunk@294690 91177308-0d34-0410-b5e6-96231b3b80d8
-
-Source: http://pkgs.fedoraproject.org/cgit/rpms/lld.git/tree/0001-CMake-Fix-pthread-handling-for-out-of-tree-builds.patch
----
- COFF/CMakeLists.txt | 2 +-
- ELF/CMakeLists.txt | 2 +-
- lib/ReaderWriter/MachO/CMakeLists.txt | 2 +-
- unittests/CoreTests/CMakeLists.txt | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/COFF/CMakeLists.txt b/COFF/CMakeLists.txt
-index 0eebe93..8f24e36 100644
---- a/COFF/CMakeLists.txt
-+++ b/COFF/CMakeLists.txt
-@@ -43,7 +43,7 @@ add_lld_library(lldCOFF
-
- LINK_LIBS
- lldCore
-- ${PTHREAD_LIB}
-+ ${LLVM_PTHREAD_LIB}
-
- DEPENDS
- COFFOptionsTableGen
-diff --git a/ELF/CMakeLists.txt b/ELF/CMakeLists.txt
-index 5652b93..0d1e5b2 100644
---- a/ELF/CMakeLists.txt
-+++ b/ELF/CMakeLists.txt
-@@ -54,7 +54,7 @@ add_lld_library(lldELF
- LINK_LIBS
- lldConfig
- lldCore
-- ${PTHREAD_LIB}
-+ ${LLVM_PTHREAD_LIB}
-
- DEPENDS
- ELFOptionsTableGen
-diff --git a/lib/ReaderWriter/MachO/CMakeLists.txt b/lib/ReaderWriter/MachO/CMakeLists.txt
-index 3b06985..5a96d87 100644
---- a/lib/ReaderWriter/MachO/CMakeLists.txt
-+++ b/lib/ReaderWriter/MachO/CMakeLists.txt
-@@ -28,7 +28,7 @@ add_lld_library(lldMachO
- LINK_LIBS
- lldCore
- lldYAML
-- ${PTHREAD_LIB}
-+ ${LLVM_PTHREAD_LIB}
- )
-
- include_directories(.)
-diff --git a/unittests/CoreTests/CMakeLists.txt b/unittests/CoreTests/CMakeLists.txt
-index 98405d5..72e7c44 100644
---- a/unittests/CoreTests/CMakeLists.txt
-+++ b/unittests/CoreTests/CMakeLists.txt
-@@ -3,5 +3,5 @@ add_lld_unittest(CoreTests
- )
-
- target_link_libraries(CoreTests
-- ${PTHREAD_LIB}
-+ ${LLVM_PTHREAD_LIB}
- )
---
-1.8.3.1
-