aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-03-22 21:35:54 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-12 12:26:36 +0000
commitbe37d7cf6f5b4db9ac366bf113a94fc22af7b752 (patch)
treea74a45196f4d6cd3dc56d3febcca7863b92246e6 /community
parente51afe3be7b20947ac68cb9c7431ce82be3b3918 (diff)
downloadaports-be37d7cf6f5b4db9ac366bf113a94fc22af7b752.tar.bz2
aports-be37d7cf6f5b4db9ac366bf113a94fc22af7b752.tar.xz
community/py-pyldap: upgrade to 3.2.0
Closes GH-5456
Diffstat (limited to 'community')
-rw-r--r--community/py-pyldap/APKBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/community/py-pyldap/APKBUILD b/community/py-pyldap/APKBUILD
index ac5f79e344..73eada5919 100644
--- a/community/py-pyldap/APKBUILD
+++ b/community/py-pyldap/APKBUILD
@@ -1,35 +1,35 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py-pyldap
-_pkgname=${pkgname#py-}
-pkgver=2.4.45
-_vermajor=${pkgver%%.*}
-_verminor=${pkgver#*.}; _verminor=${_verminor%%.*}
-pkgrel=1
+_pkgname=python-ldap
+pkgver=3.2.0
+pkgrel=0
pkgdesc="Python modules for implementing LDAP clients"
-url="https://github.com/pyldap/pyldap"
+url="https://github.com/python-ldap/python-ldap"
arch="all"
+options="!check" # depends on slapdtest
license="PSF"
-depends="libldap>=$_vermajor.$_verminor"
-makedepends="python2-dev python3-dev openldap-dev>=$_vermajor.$_verminor"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+depends="libldap py3-asn1 py3-asn1-modules"
+makedepends="python3-dev py3-setuptools openldap-dev"
+checkdepends="openldap openldap-clients"
+subpackages="py3-$_pkgname:_py3"
source="https://github.com/$_pkgname/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
+check() {
+ cd "$builddir"
+
+ python3 setup.py test
}
-_py2() {
- replaces="$pkgname"
- _py python2
+package() {
+ mkdir -p "$pkgdir"
}
_py3() {
@@ -45,4 +45,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="aea856facf73d8131087d44ea718b305c6bfc5c9b9d2d8f4cac91a1d95d32aaf40e0541a4a6ff921f9deebb509474ee16bb49fa72d417440e5c9124fa9eedfa0 pyldap-2.4.45.tar.gz"
+sha512sums="142ac4f98dfad62abb9ce47822771b4e431e4d86251f7139d99d92d0005cd6c2c1bec2b12e7ab96aa2f9d044e68623d4ddeecfc3a1820c19cd163ddd89355cd0 python-ldap-3.2.0.tar.gz"