aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-26 22:24:05 +0300
committerprspkt <prspkt@protonmail.com>2019-04-26 22:24:05 +0300
commitef472e2846c720438a76f22af0011c075fd2aab4 (patch)
tree477e2f35227671397f529e531c7f2e454fbf7c13 /community
parente04bc57a383beb47e235fbe005e4a4b8dfd5b387 (diff)
downloadaports-ef472e2846c720438a76f22af0011c075fd2aab4.tar.bz2
aports-ef472e2846c720438a76f22af0011c075fd2aab4.tar.xz
community/py3-port-for: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-port-for/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-port-for/APKBUILD b/community/py3-port-for/APKBUILD
new file mode 100644
index 0000000000..3eff3c0ff7
--- /dev/null
+++ b/community/py3-port-for/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-port-for
+_pkgname=port-for
+pkgver=0.4
+pkgrel=0
+pkgdesc="Utility and library that helps with local TCP ports management"
+url="https://github.com/kmike/port-for"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-tox"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py3
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="476b7273d868c84d7a0a6f49f93b4d0c8d4cd449adc800c7f587e5201d52234c89d6f768f9c20dbf61a55fc52d884146ab3b02db313ab2b4c6afd2f046b03c98 port-for-0.4.tar.gz"