aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-15 17:42:57 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-15 17:42:57 +0000
commitfbe71dc392173daccca7aac1fc0cae5052671122 (patch)
tree28eb045e5f85109cb72517f4c29863e724e9b4aa /community
parentbb3588132a3ab73446325cd55db24be3a78456a5 (diff)
downloadaports-fbe71dc392173daccca7aac1fc0cae5052671122.tar.bz2
aports-fbe71dc392173daccca7aac1fc0cae5052671122.tar.xz
community/perl-test-postgresql: upgrade to 1.27
Diffstat (limited to 'community')
-rw-r--r--community/perl-test-postgresql/APKBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/community/perl-test-postgresql/APKBUILD b/community/perl-test-postgresql/APKBUILD
index 5e10f96176..89f364ac34 100644
--- a/community/perl-test-postgresql/APKBUILD
+++ b/community/perl-test-postgresql/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-test-postgresql
_pkgreal=Test-PostgreSQL
-pkgver=1.26
+pkgver=1.27
pkgrel=0
pkgdesc="PostgreSQL runner for tests"
url="http://search.cpan.org/dist/Test-PostgreSQL/"
@@ -12,7 +12,7 @@ license="Artistic-2.0"
cpandepends="perl-class-accessor-lite"
cpanmakedepends="perl-test-sharedfork perl-dbd-pg perl-dbi
perl-test-pod perl-moo perl-type-tiny perl-function-parameters
- perl-file-which perl-tie-hash-method"
+ perl-file-which perl-tie-hash-method perl-module-build-tiny"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends perl-module-install"
checkdepends="perl-try-tiny"
@@ -20,27 +20,28 @@ subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TJ/TJC/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-check() {
- cd "$builddir"
- make test
-}
-
prepare() {
+ default_prepare
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
}
build() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ ./Build install --destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="c56986ab59e844272ab1d6447ed7d0ac83c3c5f5f1ad9a4f10c16505d51412ede3775f1dae28306dd1b7d461f679343bed911066ec775c58f21a88a1294c2d30 Test-PostgreSQL-1.26.tar.gz"
+sha512sums="e8f5285b358659fdcde67c711d66307926fb4dab11e70b0a69ebf42308cd879819c15f04aa8703f93a3dc447a806f0a6afb0b7d57cf538c94170c5df66d24d11 Test-PostgreSQL-1.27.tar.gz"