aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-11-04 22:38:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-07 15:15:31 +0000
commit694e4b59fbbad7baf48e8fdbff8086f13d2fc6ac (patch)
tree7a1bd3c4f8f31e8616c9bde952bdbf6f0a7726e1 /community
parent51914aa9a07ab9581eb0db317bc0539d82a94baf (diff)
downloadaports-694e4b59fbbad7baf48e8fdbff8086f13d2fc6ac.tar.bz2
aports-694e4b59fbbad7baf48e8fdbff8086f13d2fc6ac.tar.xz
community/php5-apcu: restore to community
* restore php5-acpu
Diffstat (limited to 'community')
-rw-r--r--community/php5-apcu/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/php5-apcu/APKBUILD b/community/php5-apcu/APKBUILD
new file mode 100644
index 0000000000..a84b85e85f
--- /dev/null
+++ b/community/php5-apcu/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+_php=php5
+pkgname=${_php}-apcu
+_pkgreal=apcu
+# release 5 is php7+
+pkgver=4.0.11
+_pkgver=${pkgver/_rc/RC}
+pkgrel=1
+pkgdesc="PHP extension APC User Cache"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="${_php}-dev autoconf"
+makedepends="$pecldepends pcre-dev"
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+_builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$_builddir"
+ phpize5
+ ./configure \
+ --prefix=/usr \
+ --with-php-config=/usr/bin/php-config5
+ make
+}
+
+check() {
+ cd "$_builddir"
+ # test failures reported to php
+ # the test asks for an email address due to this failure
+ # make test
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/$_php/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/$_php/conf.d/$_pkgreal.ini
+}
+
+sha512sums="e3b97066240e33850419e96f0fd9df0e66ee3b0fa238c418e07ac639d07439e9edfa1696e56a620e33f1ffc0993c57bde585b0c170b22995e7d5c0ae550b7899 apcu-4.0.11.tgz"