aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:06 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:49 +0200
commit7b0f6ebff877497471a50b807f83a8e00898bee9 (patch)
treec044f13c488ff2b0bdd1d4a979dc52ebbcccf4b5 /community
parentf41791d0026c3b6657c876a0fc1d60b6f23205ab (diff)
downloadaports-7b0f6ebff877497471a50b807f83a8e00898bee9.tar.bz2
aports-7b0f6ebff877497471a50b807f83a8e00898bee9.tar.xz
community/py3-xdg: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-xdg/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-xdg/APKBUILD b/community/py3-xdg/APKBUILD
new file mode 100644
index 0000000000..2d85e16a01
--- /dev/null
+++ b/community/py3-xdg/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=py3-xdg
+_pkgname=pyxdg
+pkgver=0.26
+pkgrel=1
+pkgdesc="A python library to access freedesktop.org standards"
+options="!check" # Test fails
+url="https://freedesktop.org/wiki/Software/pyxdg"
+arch="noarch"
+license="LGPL-2.1-only"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-nose hicolor-icon-theme"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-xdg" # Backwards compatibility
+provides="py-xdg=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ nosetests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f5306e6e15af07df2599017500fc8ad83e722e5d5c6e4fda014aab1d77df92a3c3199a5be7a889faaecab72861e9910be9d80142d29856eb7a11f6ab9a923bd2 pyxdg-0.26.tar.gz"