aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-15 00:32:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-15 00:32:30 -0300
commitd1c403c9439ec47617fca2290e510612d9b1d017 (patch)
tree8064e70d59a62bae3e82193341f754ff05da75c9 /community
parent52a89765b1ad1b8dffd826eb6d8108f550cb3688 (diff)
downloadaports-d1c403c9439ec47617fca2290e510612d9b1d017.tar.bz2
aports-d1c403c9439ec47617fca2290e510612d9b1d017.tar.xz
community/sn0int: use sphinx-build-3
Diffstat (limited to 'community')
-rw-r--r--community/sn0int/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/sn0int/APKBUILD b/community/sn0int/APKBUILD
index c456a8dbbf..047bb8faeb 100644
--- a/community/sn0int/APKBUILD
+++ b/community/sn0int/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: kpcyrd <git@rxv.cc>
pkgname=sn0int
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="Semi-automatic OSINT framework and package manager"
url="https://github.com/kpcyrd/sn0int"
arch="x86_64 !armhf !armv7" # limited by cargo
@@ -11,7 +11,7 @@ makedepends="
cargo
sqlite-dev
libseccomp-dev
- py-sphinx
+ py3-sphinx
wget
"
subpackages="$pkgname-doc
@@ -19,10 +19,9 @@ subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-fish-completion:fishcomp:noarch
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kpcyrd/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kpcyrd/sn0int/archive/v$pkgver.tar.gz"
build() {
- cd "$builddir"
cargo build --release --locked
mkdir -p completions
@@ -30,12 +29,10 @@ build() {
"target/release/sn0int" completions zsh > completions/_sn0int
"target/release/sn0int" completions fish > completions/sn0int.fish
- make -C docs man
+ make -C docs man SPHINXBUILD=sphinx-build-3
}
check() {
- cd "$builddir"
-
wget https://geolite.maxmind.com/download/geoip/database/GeoLite2-City.tar.gz \
https://geolite.maxmind.com/download/geoip/database/GeoLite2-ASN.tar.gz
cargo run --release --locked --example maxmind -- \