aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-08 16:15:20 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-30 12:38:37 +0000
commite306e7f50da240fab2f71e0ac9561485bc48d298 (patch)
tree7c5930edbbf523d3f990c9847a2c6913f7861322 /community
parent835fd3c4f8b94f2f248aa4d98c38595adc1bcd16 (diff)
downloadaports-e306e7f50da240fab2f71e0ac9561485bc48d298.tar.bz2
aports-e306e7f50da240fab2f71e0ac9561485bc48d298.tar.xz
main/fstrm: move from community
Diffstat (limited to 'community')
-rw-r--r--community/fstrm/APKBUILD45
-rw-r--r--community/fstrm/reduce-testruns.patch39
2 files changed, 0 insertions, 84 deletions
diff --git a/community/fstrm/APKBUILD b/community/fstrm/APKBUILD
deleted file mode 100644
index 4a1ba80b73..0000000000
--- a/community/fstrm/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Contributor: tcely <tcely@users.noreply.github.com>
-# Maintainer: tcely <fstrm+aports@tcely.33mail.com>
-pkgname="fstrm"
-pkgver="0.5.0"
-pkgrel=0
-pkgdesc="Frame Streams implementation in C"
-url="https://github.com/farsightsec/fstrm"
-arch="all"
-# check failure on s390x reported upstream:
-# https://github.com/farsightsec/fstrm/issues/58
-license="MIT"
-depends=""
-depends_dev="libevent-dev"
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://dl.farsightsecurity.com/dist/$pkgname/$pkgname-$pkgver.tar.gz
- reduce-testruns.patch"
-
-build() {
- cd "$builddir"
-
- ./configure \
- --build="$CBUILD" \
- --host="$CHOST" \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man
- make
-}
-
-check() {
- cd "$builddir"
-
- make check
-}
-
-package() {
- cd "$builddir"
-
- make -j1 DESTDIR="$pkgdir" install
-}
-
-sha512sums="cc60d8974d73d4f5327c46fe642151c88cf8d670ac9bb5db6cb5990b6c0995a0e09c9ae1a6c86ecbfd35fe03664b5402becd68bc6e81e83e9f4b84668d866f25 fstrm-0.5.0.tar.gz
-1c687ee7741fb20a571c3d7d3fb9a1cf09709d83d66d788eb09835750ee2313aa565f74d35a9cdece2154e1b8c41c68b268ca8f5bc33f8d14550ebe46880d550 reduce-testruns.patch"
diff --git a/community/fstrm/reduce-testruns.patch b/community/fstrm/reduce-testruns.patch
deleted file mode 100644
index 2566c17851..0000000000
--- a/community/fstrm/reduce-testruns.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/t/run_test_fstrm_io_file.sh b/t/run_test_fstrm_io_file.sh
-index 554fbe8..ee00985 100755
---- a/t/run_test_fstrm_io_file.sh
-+++ b/t/run_test_fstrm_io_file.sh
-@@ -9,7 +9,7 @@ fi
-
- for QUEUE_MODEL in SPSC MPSC; do
- for NUM_THREADS in 1 4 16; do
-- for NUM_MESSAGES in 1 1000 100000; do
-+ for NUM_MESSAGES in 1 1000 10000; do
- $DIRNAME/$TNAME "$FILENAME" $QUEUE_MODEL $NUM_THREADS $NUM_MESSAGES
- done
- done
-diff --git a/t/run_test_fstrm_io_tcp.sh b/t/run_test_fstrm_io_tcp.sh
-index f8a14ba..c59e997 100755
---- a/t/run_test_fstrm_io_tcp.sh
-+++ b/t/run_test_fstrm_io_tcp.sh
-@@ -9,7 +9,7 @@ fi
-
- for QUEUE_MODEL in SPSC MPSC; do
- for NUM_THREADS in 1 4 16; do
-- for NUM_MESSAGES in 1 1000 100000; do
-+ for NUM_MESSAGES in 1 1000 10000; do
- $DIRNAME/$TNAME $SOCKADDR $QUEUE_MODEL $NUM_THREADS $NUM_MESSAGES
- done
- done
-diff --git a/t/run_test_fstrm_io_unix.sh b/t/run_test_fstrm_io_unix.sh
-index ac3080e..cf6ce82 100755
---- a/t/run_test_fstrm_io_unix.sh
-+++ b/t/run_test_fstrm_io_unix.sh
-@@ -9,7 +9,7 @@ fi
-
- for QUEUE_MODEL in SPSC MPSC; do
- for NUM_THREADS in 1 4 16; do
-- for NUM_MESSAGES in 1 1000 100000; do
-+ for NUM_MESSAGES in 1 1000 10000; do
- $DIRNAME/$TNAME "$SOCKNAME" $QUEUE_MODEL $NUM_THREADS $NUM_MESSAGES
- done
- done