aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2019-04-27 23:22:33 +0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-27 21:02:51 +0000
commitefef9ff68c9eaee29514270a7421143e4acac458 (patch)
treeec1361e967271ac04f8f2b2bc113113ede775e59 /community
parent4366f58a8d03e06a5e7db6c1bf64e2e7bd6d34e4 (diff)
downloadaports-efef9ff68c9eaee29514270a7421143e4acac458.tar.bz2
aports-efef9ff68c9eaee29514270a7421143e4acac458.tar.xz
community/i3wm: add missing perl-anyevent-i3 dependency
* separate i3-save-tree as subpackage due to extra dependencies Closes GH-6354
Diffstat (limited to 'community')
-rw-r--r--community/i3wm/APKBUILD39
1 files changed, 32 insertions, 7 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
index cda88b5e16..93e8af6efc 100644
--- a/community/i3wm/APKBUILD
+++ b/community/i3wm/APKBUILD
@@ -2,17 +2,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=i3wm
pkgver=4.16.1
-pkgrel=1
+pkgrel=2
pkgdesc="Improved dynamic tiling window manager"
url="https://i3wm.org"
arch="all"
license="BSD-3-Clause"
-makedepends="$depends_dev bison flex libxcb-dev xcb-util-cursor-dev
- xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
- yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev
- xcb-util-xrm-dev perl"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://i3wm.org/downloads/i3-$pkgver.tar.bz2
+makedepends="
+ bison
+ cairo-dev
+ flex
+ libev-dev
+ libxcb-dev
+ libxkbcommon-dev
+ pango-dev
+ pcre-dev
+ perl
+ startup-notification-dev
+ xcb-util-cursor-dev
+ xcb-util-keysyms-dev
+ xcb-util-wm-dev
+ xcb-util-xrm-dev
+ yajl-dev
+ "
+subpackages="
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-save_tree:savetree;noarch
+ "
+source="
+ https://i3wm.org/downloads/i3-$pkgver.tar.bz2
i3wm-musl-glob-tilde.patch
"
builddir="$srcdir/i3-$pkgver"
@@ -39,5 +57,12 @@ package() {
install -m644 man/*.1 "$pkgdir"/usr/share/man/man1/
}
+savetree() {
+ pkgdesc="Session export tool for $pkgname"
+ depends="$pkgname=$pkgver perl-anyevent-i3"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/i3-save-tree "$subpkgdir"/usr/bin/
+}
+
sha512sums="3e328f8c7216697c5e484ca854605350f78844e24cc6cfb9c10e71368c2c0457387a14f819abdf8be2370d437889297f452fbf63f3924766ca81c157ab27e1b0 i3-4.16.1.tar.bz2
c6ae3f22d0303da5de7ca4c92734b043a76d7447559fe2ffc308a8d135076cf05ee53ef63eb28c1bd628a1edfb2d1a0ed2d090836cb5fc70f2b882ee1105dad3 i3wm-musl-glob-tilde.patch"