aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-12 11:08:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-12 12:47:02 +0100
commitf5e4e962164d249e66bb33ea81492bb6eebb04b0 (patch)
treea5dd30529d70db273b483833f69971f64d457191 /community
parentba45b4ed67deb86e135a7caccdc0ad47597e543e (diff)
downloadaports-f5e4e962164d249e66bb33ea81492bb6eebb04b0.tar.bz2
aports-f5e4e962164d249e66bb33ea81492bb6eebb04b0.tar.xz
community/libnitrokey: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/libnitrokey/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/libnitrokey/APKBUILD b/community/libnitrokey/APKBUILD
new file mode 100644
index 0000000000..74c47126dd
--- /dev/null
+++ b/community/libnitrokey/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libnitrokey
+pkgver=3.5
+pkgrel=0
+arch="all"
+url="https://nitrokey.com/"
+pkgdesc="Communicate with Nitrokey devices in a clean and easy manner"
+license="LGPL-3.0-or-later"
+makedepends="cmake hidapi-dev"
+source="https://github.com/Nitrokey/libnitrokey/archive/v$pkgver/libnitrokey-v$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="d2a95071e92d839c8cde4ac1435158bb469c25662f2988a4e824dbc0dfe83af841e6d04589293deddd77746dbec17b30c50fab69af58cc727ed5e0f2dbd0b5e7 libnitrokey-v3.5.tar.gz"