aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-17 11:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-17 12:20:35 +0000
commit48069127295e92dfb715a0093733127ec8ec295e (patch)
tree7e6be6892f143661d8a261dd20cfafc5c2ff2e75 /community
parentb7d127307b6bcdfdfd024e78cbe3a948ba998bd8 (diff)
downloadaports-48069127295e92dfb715a0093733127ec8ec295e.tar.bz2
aports-48069127295e92dfb715a0093733127ec8ec295e.tar.xz
communit/libgxps: move from testing
needed by atril
Diffstat (limited to 'community')
-rw-r--r--community/libgxps/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/libgxps/APKBUILD b/community/libgxps/APKBUILD
new file mode 100644
index 0000000000..558723405c
--- /dev/null
+++ b/community/libgxps/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Paul Bredbury <brebs@sent.com>
+pkgname=libgxps
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="XPS documents library & conversion utilities"
+url="https://wiki.gnome.org/action/show/Projects/libgxps"
+arch="all"
+license="LGPL-2.1-or-later"
+depends=""
+makedepends="gobject-introspection-dev glib-dev gtk+3.0-dev libarchive-dev libjpeg-turbo-dev tiff-dev lcms2-dev meson"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/GNOME/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ meson --prefix=/usr --libdir=lib --buildtype=release build/
+ ninja -v -C build/
+}
+
+check() {
+ cd "$builddir/build"
+ ninja test
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C build/ install
+}
+
+sha512sums="09646e390cbfa667ad9aef52466c24f6a2499ac02d1296e73919574d4670be6a8880e4e491f875719d6946998d2cf1d98fadbb7102f614e839f986fbc38fca65 libgxps-0.3.1.tar.gz"