aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-10-17 01:09:04 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-10-17 01:09:04 +0200
commitc0ee904e0e547078d3ccf7db685f59f70dee64fd (patch)
tree596c0ec4017b77e265131fab334546e2ae5db761 /community
parente8aab477f3c8c716ddd3dde2e36c9154b7bd6e86 (diff)
downloadaports-c0ee904e0e547078d3ccf7db685f59f70dee64fd.tar.bz2
aports-c0ee904e0e547078d3ccf7db685f59f70dee64fd.tar.xz
community/ssh-getkey-gitlab: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/ssh-getkey-gitlab/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/community/ssh-getkey-gitlab/APKBUILD b/community/ssh-getkey-gitlab/APKBUILD
new file mode 100644
index 0000000000..8edafa5b67
--- /dev/null
+++ b/community/ssh-getkey-gitlab/APKBUILD
@@ -0,0 +1,19 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname="ssh-getkey-gitlab"
+pkgver="0.1.0"
+pkgrel=0
+pkgdesc="A script to be used as AuthorizedKeysCommand in sshd to look up user's public keys in GitLab or GitHub"
+url="https://github.com/jirutka/ssh-getkey-gitlab"
+arch="noarch"
+license="MIT"
+depends="ssl_client"
+options="!check" # no tests provided
+source="https://github.com/jirutka/ssh-getkey-gitlab/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+sha512sums="b034f17eb1f9935fbd259040f784808f7d3c95d8c5883f857e5166063fc29c107e7672de80c9035e2373aa1443d8691f2cf107ed3f0853f605d47e39dca823b4 ssh-getkey-gitlab-0.1.0.tar.gz"