aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-19 02:33:37 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-19 02:33:37 +0200
commit091a6d804005b543a41a5808b931aa4314a67951 (patch)
treeec552beb9d47aa2c43f9ca917fbe95f41ecad32e /community
parentde1467c6842daa4a1fbcc471eafaa9684d67da6c (diff)
downloadaports-091a6d804005b543a41a5808b931aa4314a67951.tar.bz2
aports-091a6d804005b543a41a5808b931aa4314a67951.tar.xz
community/postgresql-orafce: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/postgresql-orafce/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/postgresql-orafce/APKBUILD b/community/postgresql-orafce/APKBUILD
new file mode 100644
index 0000000000..0c91d20391
--- /dev/null
+++ b/community/postgresql-orafce/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=postgresql-orafce
+_pkgname=orafce
+pkgver=3.4.0
+_pkgver=VERSION_${pkgver//./_}
+pkgrel=0
+pkgdesc="Oracle's compatibility functions and packages for PostgreSQL"
+url="https://github.com/orafce/orafce"
+arch="all"
+license="BSD"
+depends="postgresql"
+makedepends="bison flex postgresql-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/orafce/$_pkgname/archive/$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$_pkgver"
+options="!check" # XXX: installcheck requires running PostgreSQL
+
+build() {
+ cd "$builddir"
+ make USE_PGXS=1 all
+}
+
+package() {
+ cd "$builddir"
+
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"
+ mv ./usr/share/doc/postgresql/extension \
+ ./usr/share/doc/$pkgname
+ rmdir ./usr/share/doc/postgresql
+}
+
+sha512sums="576fd6d818528d6fa980a911b355fe31b131d87f5d758a78eab4f9c47546d039ae93ca6ac253312b3828da91147ae8c852685ed312a5f9ad02b8fc53b55a9e42 postgresql-orafce-3.4.0.tar.gz"