aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-03-18 05:51:53 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 20:52:41 +0000
commit314b24d565fc782675582fcedf74add802a5fc8c (patch)
treec3a0d381249f4c35f3a80fd2474b4653e65e779e /community
parenta0e864e6ab838ba57e14f5b956192a01ed8c2cbc (diff)
downloadaports-314b24d565fc782675582fcedf74add802a5fc8c.tar.bz2
aports-314b24d565fc782675582fcedf74add802a5fc8c.tar.xz
testing/py-jedi: move to community
Diffstat (limited to 'community')
-rw-r--r--community/py-jedi/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py-jedi/APKBUILD b/community/py-jedi/APKBUILD
new file mode 100644
index 0000000000..b649c4489b
--- /dev/null
+++ b/community/py-jedi/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-jedi
+_pkgname=jedi
+pkgver=0.13.3
+pkgrel=0
+pkgdesc="Awesome autocompletion and static analysis library for python"
+url="https://pypi.org/project/jedi"
+arch="noarch"
+license="MIT"
+makedepends="py3-setuptools python3-dev"
+checkdepends="pytest py-parso py-tox"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py3-jedi"
+
+build() {
+ python3 setup.py build
+}
+
+_getpythonver(){
+ echo $(python3 -c 'import sys; print("{}{}".format(sys.version_info.major, sys.version_info.minor))')
+}
+
+check() {
+ tox -e py$(_getpythonver)
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b20fc75d909f9b7c6db434f468e7cefd9768991ca72d7026df9c4000805675a979f9e40f75623770df44bf8919a46270bcaa8e28d991a2299c64bc4c60d873fc jedi-0.13.3.tar.gz"