aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 19:32:11 -0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-08-29 06:07:30 +0000
commita1d472a7b19134c1f13339cfc14688067269a6b1 (patch)
treeb1482b39687c11de5079977be5fa6b358e474b1d /community
parentad194b5a8882dcc3249ca8d58f322e35be21839d (diff)
downloadaports-a1d472a7b19134c1f13339cfc14688067269a6b1.tar.bz2
aports-a1d472a7b19134c1f13339cfc14688067269a6b1.tar.xz
main/cython: move from community
Diffstat (limited to 'community')
-rw-r--r--community/cython/APKBUILD70
1 files changed, 0 insertions, 70 deletions
diff --git a/community/cython/APKBUILD b/community/cython/APKBUILD
deleted file mode 100644
index 6d54accd04..0000000000
--- a/community/cython/APKBUILD
+++ /dev/null
@@ -1,70 +0,0 @@
-# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
-# Contributor: Oleg Titov <oleg.titov@gmail.com>
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=cython
-pkgver=0.29.13
-pkgrel=0
-pkgdesc="Cython is an optimising static compiler for both the Python & the extended Cython programming languages."
-url="https://cython.org"
-arch="all"
-license="Apache-2.0"
-options="!check" # several tests fail
-makedepends="py2-setuptools py3-setuptools python2-dev python3-dev"
-subpackages="cython2:_py2 cython3:_py3 cython-doc"
-source="cython-$pkgver.tar.gz::https://github.com/cython/cython/archive/$pkgver.tar.gz"
-
-# compatible fix for removing dev subpkg from apkbuild
-# cython is not a library but a compiler and does not need a dev subpackage
-provides=cython-dev
-
-prepare() {
- cp -r "$builddir" "$builddir"-py2
-}
-
-build() {
- python3 setup.py build
-
- cd "$builddir"-py2
- python2 setup.py build
-}
-
-check() {
- make test
-}
-
-package() {
- mkdir -p "$pkgdir"
-
- install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/cython/license"
- install -Dm 644 README.rst "$pkgdir/usr/share/doc/cython/readme.rst"
-}
-
-_py2() {
- cd "$builddir"-py2
- _py python2
-
- local f; for f in cygdb cython cythonize; do
- mv "$subpkgdir"/usr/bin/$f "$subpkgdir"/usr/bin/${f}2
- done
-}
-
-_py3() {
- cd "$builddir"
- _py python3
-
- local f; for f in cygdb cython cythonize; do
- mv "$subpkgdir"/usr/bin/$f "$subpkgdir"/usr/bin/${f}3
- ln -s ${f}3 "$subpkgdir"/usr/bin/$f
- done
-}
-
-_py() {
- _python="$1"
- pkgdesc="$pkgdesc (for $_python)"
- depends="$depends $_python"
- install_if="cython=$pkgver-r$pkgrel $_python"
-
- $_python setup.py install --prefix=/usr --root="$subpkgdir" --optimize=1
-}
-
-sha512sums="79efebfddabf31a046ae86a2c2170e0956098f4b1c7b8bbd338d30be7c96c31ee2d648332fc16ad9cf1e5d0ea4ca1a070b2d31ccbeae0c0f86a2f7700b92f656 cython-0.29.13.tar.gz"