aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-04-19 22:20:19 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-19 22:20:19 +0000
commitf5d21c4c38be117a112d033551263923ae97a425 (patch)
treeaadb446e13df86261fd10dec6f21c604ce7d4bce /community
parent57d39405ad7442dd1d9579b5a2bcc78dbf6f0330 (diff)
downloadaports-f5d21c4c38be117a112d033551263923ae97a425.tar.bz2
aports-f5d21c4c38be117a112d033551263923ae97a425.tar.xz
community/mtd-utils: log output of test-suite on fail
Diffstat (limited to 'community')
-rw-r--r--community/mtd-utils/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/mtd-utils/APKBUILD b/community/mtd-utils/APKBUILD
index 36396d1887..6b52c0eff0 100644
--- a/community/mtd-utils/APKBUILD
+++ b/community/mtd-utils/APKBUILD
@@ -49,8 +49,14 @@ build() {
make
}
+_cat_found_file() {
+ local _rc="$?"
+ find -name "$1" -type f -ls -printf '%P {{{\n' -exec cat -v -n '{}' ';' -printf '}}} %P\n'
+ return "$_rc"
+}
+
check() {
- make check
+ make check || _cat_found_file 'test-suite.log'
}
flash() {