aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-05 03:33:17 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-06-05 07:19:20 +0000
commit388e84804cf16a90279beea36086fd81a106f338 (patch)
treed75733366658f2088898096dbe4b5f6d24a17c60 /community
parent9aff193e6b30a5fd0f818dd79ea083bc70d64527 (diff)
downloadaports-388e84804cf16a90279beea36086fd81a106f338.tar.bz2
aports-388e84804cf16a90279beea36086fd81a106f338.tar.xz
community/astyle: modernize, fix url, fix license
Diffstat (limited to 'community')
-rw-r--r--community/astyle/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/astyle/APKBUILD b/community/astyle/APKBUILD
index 56b561887b..dc2c9dd592 100644
--- a/community/astyle/APKBUILD
+++ b/community/astyle/APKBUILD
@@ -1,29 +1,24 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=astyle
pkgver=3.1
-pkgrel=1
+pkgrel=2
pkgdesc="An automatic code formatter"
-url="http://sourceforge.net/projects/astyle"
+options="!check" # No testsuite
+url="https://sourceforge.net/projects/astyle/"
arch="all"
-license="LGPL"
+license="MIT"
source="https://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz
-fix-ppc64le-build.patch"
+ fix-ppc64le-build.patch"
builddir="$srcdir/$pkgname"
build() {
- cd "$builddir/build/gcc"
+ cd build/gcc
make release
}
-check() {
- cd "$builddir/build/gcc"
- # upstream do not provide tests
- ./bin/astyle --version
-}
-
package() {
- cd "$builddir/build/gcc"
+ cd build/gcc
install -Dm0755 bin/astyle "$pkgdir/usr/bin/astyle"
}