aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-23 00:20:24 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-06 20:42:59 +0000
commit3a3e913ab7cc1276b5ff77763dfd52306bc60988 (patch)
treebe61e17e049cbc8a13d2dace2144712e59128557 /community
parent0c7d3793391202eff0009c1dac768d4f2449b356 (diff)
downloadaports-3a3e913ab7cc1276b5ff77763dfd52306bc60988.tar.bz2
aports-3a3e913ab7cc1276b5ff77763dfd52306bc60988.tar.xz
community/xxhash: update to 0.7.0
Diffstat (limited to 'community')
-rw-r--r--community/xxhash/APKBUILD52
1 files changed, 24 insertions, 28 deletions
diff --git a/community/xxhash/APKBUILD b/community/xxhash/APKBUILD
index 45fffda123..346ffc7f82 100644
--- a/community/xxhash/APKBUILD
+++ b/community/xxhash/APKBUILD
@@ -1,56 +1,52 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=xxhash
_pkgname=xxHash
-pkgver=0.6.5
+pkgver=0.7.0
_pypkg=python-xxhash
-_pyver=0.6.1
-pkgrel=2
+_pyver=1.3.0
+pkgrel=0
pkgdesc="Extremely fast non-cryptographic hash algorithm"
url="http://www.xxhash.com"
arch="all"
-license="BSD GPL"
-depends=""
+license="BSD-2-Clause GPL-2.0-or-later"
makedepends="python2-dev python3-dev py-setuptools"
-subpackages="$pkgname-dev $pkgname-doc py2-$pkgname:_py2 py3-$pkgname:_py3"
+subpackages="$pkgname-dev $pkgname-doc py2-$pkgname:_py2 py3-$pkgname:_py3 lib$pkgname:libs"
source="$_pkgname-$pkgver.tar.gz::https://github.com/Cyan4973/$_pkgname/archive/v$pkgver.tar.gz
- $_pypkg-$pkgver.tar.gz::https://github.com/ifduyue/$_pypkg/archive/v$_pyver.tar.gz
+ $_pypkg-$_pyver.tar.gz::https://github.com/ifduyue/$_pypkg/archive/v$_pyver.tar.gz
lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
"
builddir="$srcdir/"$_pkgname-$pkgver
-pybuilddir="$srcdir/"$_pypkg-$_pyver
+_pybuilddir="$srcdir/"$_pypkg-$_pyver
build() {
- cd "$builddir"
sed -i 's|--leak-check=yes|-v --leak-check=full --show-leak-kinds=all|' Makefile
- make CPPFLAGS= xxhsum
+ make
- cd "$pybuilddir"
- ln -s "$srcdir"/$_pkgname-$pkgver/xxhash.c ./xxhash/xxhash.c
- ln -s "$srcdir"/$_pkgname-$pkgver/xxhash.h ./xxhash/xxhash.h
+ cd "$_pybuilddir"
+ ln -s "$srcdir"/$_pkgname-$pkgver/xxhash.c ./deps/xxhash/xxhash.c
+ ln -s "$srcdir"/$_pkgname-$pkgver/xxhash.h ./deps/xxhash/xxhash.h
+ ln -s "$srcdir"/$_pkgname-$pkgver/xxh3.h ./deps/xxhash/xxh3.h
python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
case "$CARCH" in
armhf) return 0;; # due to "Bus error"
- *) make check;;
+ *)
+ make check
+ cd "$_pybuilddir"
+ python2 setup.py test
+ python3 setup.py test
+ ;;
esac
}
package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
- mkdir -p "$pkgdir"/usr/include/xxhash
- mkdir -p "$pkgdir"/usr/share/man/man1
- mkdir -p "$pkgdir"/usr/share/doc/xxhash
- install -m755 xxhsum "$pkgdir"/usr/bin
- install -m644 xxhsum.1 "$pkgdir"/usr/share/man/man1
- install -m644 LICENSE "$pkgdir"/usr/share/doc/xxhash
- install -m644 xxhash.h "$pkgdir"/usr/include/xxhash
- install -m644 xxhash.c "$pkgdir"/usr/include/xxhash
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ rm -rf "$pkgdir"/usr/lib/libxxhash.a
}
_py2() {
@@ -67,10 +63,10 @@ _py() {
depends=xxhash
install_if="py-xxhash=$pkgver-r$pkgrel $python"
- cd "$pybuilddir"
+ cd "$_pybuilddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="085643b52e091ac0eedd54c4459220b3643d825ca71a11e952d00ea2041c570ff57d8553d0378f34e038ca9ee3b40d2048ed02d44d5aff1fbfcbf5e642487ba0 xxHash-0.6.5.tar.gz
-72a99d744ccaac830e9789053acb9728b2da457c7841e2aae96e9748450f09366b9830f6d92b62ac494e938f43c1fea7910c9d5257824ae33c1fe48f199ed9cc python-xxhash-0.6.5.tar.gz
+sha512sums="2d7a06a5cabc945ac841df4451a744f0a666e4afcce77f5eea70bd68547ac46ebf776dd0e3645ef0204c7ff1dea3f5ff8228a8d9894dae0077f865ffdc123c66 xxHash-0.7.0.tar.gz
+4aafc2c9f9eac13e6bae11c49ab2342754c2afebe9b2430945ab32e56cc651b4cbbc08fdc2caf339aafb971a1ae3cd76b1983c8780f3b4f9df64a7e19e3927ea python-xxhash-1.3.0.tar.gz
5503fc4177bbbc8ebac3c921be1a560b7197d1e66cb94064013fa5df750c6659520bb8ddec689b2b3ccb51cec3088508c7dce4bc2cf8c6127053d96e39cd7e6e lift-XXH_FORCE_MEMORY_ACCESS-condition.patch"