aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-29 07:24:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-29 07:28:20 +0000
commit4dde5d5a86737f9d7f5ce23bd022dc60dc81d527 (patch)
tree4982b6ed3b0f0a51b812e178bda71f0ddcdd6c5e /community
parent1ccb9d8cb41ebf8ef461c30bcb095102b8763356 (diff)
downloadaports-4dde5d5a86737f9d7f5ce23bd022dc60dc81d527.tar.bz2
aports-4dde5d5a86737f9d7f5ce23bd022dc60dc81d527.tar.xz
community/gimp: move from main
Diffstat (limited to 'community')
-rw-r--r--community/gimp/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/gimp/APKBUILD b/community/gimp/APKBUILD
new file mode 100644
index 0000000000..ae795a9a32
--- /dev/null
+++ b/community/gimp/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gimp
+pkgver=2.8.22
+pkgrel=1
+pkgdesc="GNU Image Manipulation Program"
+url="http://www.gimp.org/"
+arch="all"
+license="GPLv3+"
+depends="dbus"
+makedepends="gtk+-dev libxpm-dev libxmu-dev librsvg-dev dbus-glib-dev
+ libexif-dev desktop-file-utils intltool gegl-dev tiff-dev
+ libjpeg-turbo-dev libpng-dev iso-codes-dev lcms2-dev poppler-dev babl-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gimp.org/mirror/pub/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-dependency-tracking \
+ --sysconfdir=/etc \
+ --enable-mp \
+ --enable-gimp-console \
+ --disable-python \
+ --with-gvfs \
+ --with-gif-compression=lzw \
+ --without-aa
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/gimptool* "$subpkgdir"/usr/bin
+}
+
+sha512sums="84a78d428282538b606b3cd1ff571e52c3d828fceade171b2012bc1cdcb85919fc7734e7e6c45ed3a8683657fa580412b32c1b511b8a512172a8c1df930493e6 gimp-2.8.22.tar.bz2"