aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-10-31 09:13:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:34:00 +0000
commit500f55b64f3f318a1842a0912354c85d17ccec4d (patch)
tree055e765f1e7be19593e63cccc4c81dc41c0d23e6 /community
parent4faa6bbf8cfd887e0216185e0f5fd38b69de7c86 (diff)
downloadaports-500f55b64f3f318a1842a0912354c85d17ccec4d.tar.bz2
aports-500f55b64f3f318a1842a0912354c85d17ccec4d.tar.xz
community/py3-msgpack: rebuild against python 3.8
Diffstat (limited to 'community')
-rw-r--r--community/py3-msgpack/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-msgpack/APKBUILD b/community/py3-msgpack/APKBUILD
index 978b27842f..e9f9e96060 100644
--- a/community/py3-msgpack/APKBUILD
+++ b/community/py3-msgpack/APKBUILD
@@ -9,7 +9,7 @@ url="https://msgpack.org/"
arch="all"
license="Apache-2.0"
depends="python3"
-makedepends="python3-dev py3-setuptools cython3"
+makedepends="python3-dev py3-setuptools cython"
checkdepends="py3-pytest py3-pluggy"
source="$_pkgname-$pkgver.tar.gz::https://github.com/msgpack/msgpack-python/archive/v$pkgver.tar.gz"
builddir="$srcdir/msgpack-python-$pkgver"
@@ -31,7 +31,8 @@ check() {
s390x) _pyarch=s390x;;
esac
- env PYTHONPATH="$PWD/build/lib.linux-$_pyarch-3.7" pytest-3 test
+ local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
+ env PYTHONPATH="$PWD/build/lib.linux-$_pyarch-$_py3ver" pytest-3 test
}
package() {