aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-28 15:01:42 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-28 15:04:09 +0000
commit58808e6af74f12fee39eeb9c337afcc925cf92f4 (patch)
treecd3e034978df317442f745531b81651a5f9154a3 /community
parent3f9fbd5fea7ab25996bd11af81862c560f50a24e (diff)
downloadaports-58808e6af74f12fee39eeb9c337afcc925cf92f4.tar.bz2
aports-58808e6af74f12fee39eeb9c337afcc925cf92f4.tar.xz
community/lua-bit32: remove duplicate aport
Diffstat (limited to 'community')
-rw-r--r--community/lua-bit32/APKBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/community/lua-bit32/APKBUILD b/community/lua-bit32/APKBUILD
deleted file mode 100644
index 720915e715..0000000000
--- a/community/lua-bit32/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=lua-bit32
-_pkgname=lua-compat-5.2
-pkgver=5.3.0
-pkgrel=1
-pkgdesc="Lua 5.2 bit manipulation library"
-url="https://github.com/keplerproject/lua-compat-5.2"
-arch="all"
-license="MIT"
-makedepends=""
-subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/archive/bitlib-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-bitlib-$pkgver"
-
-_luaversions="5.1 5.2 5.3"
-for _v in $_luaversions; do
- makedepends="$makedepends lua$_v-dev luarocks$_v"
- subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
-done
-
-build() {
- cd "$builddir"
-
- local lver; for lver in $_luaversions; do
- msg "Building for Lua $lver..."
-
- luarocks-$lver \
- CC="$CC" \
- CFLAGS="$CFLAGS -fPIC" \
- LUA_INCDIR="$(pkg-config --variable=includedir lua$lver)" \
- LUA_LIBDIR="$(pkg-config --variable=libdir lua$lver)" \
- make --tree=./build rockspecs/bit32-$pkgver-1.rockspec
- done
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_subpackage() {
- local lver="${subpkgname:3:3}"
- pkgdesc="$pkgdesc (for Lua $lver)"
- depends="lua$lver"
- install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
- local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/bit32/$pkgver-1"
-
- cd "$builddir"
- install -D -m 755 build/lib/lua/$lver/bit32.so \
- "$subpkgdir"/usr/lib/lua/$lver/bit32.so
-
- mkdir -p "$rockdir"
- echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
-}
-
-sha512sums="234807e201197bc27720864a328f5b63a9fe8bf88bf1fb64cd178532c0745a330b23455fcff0e50d365034f3e43af3c835de7f10a685275da66a7a1ca873e90a lua-bit32-5.3.0.tar.gz"