aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-12 21:10:41 +0300
committerprspkt <prspkt@protonmail.com>2019-08-12 21:14:41 +0300
commit8a10ce9d9b7fd20d86215a1c60dde7a2ad0e06fe (patch)
treec4bf63a2a12fcf17099da30caab40bb03957f912 /community
parent0ad1e99d82523a13f57e86141704087df2b4badd (diff)
downloadaports-8a10ce9d9b7fd20d86215a1c60dde7a2ad0e06fe.tar.bz2
aports-8a10ce9d9b7fd20d86215a1c60dde7a2ad0e06fe.tar.xz
community/py-idna-ssl: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community')
-rw-r--r--community/py-idna-ssl/APKBUILD53
-rw-r--r--community/py3-idna-ssl/APKBUILD31
2 files changed, 31 insertions, 53 deletions
diff --git a/community/py-idna-ssl/APKBUILD b/community/py-idna-ssl/APKBUILD
deleted file mode 100644
index bdd340f500..0000000000
--- a/community/py-idna-ssl/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-idna-ssl
-_pkgname=${pkgname/py-/}
-pkgver=1.1.0
-pkgrel=1
-pkgdesc="Patch ssl.match_hostname for Unicode(idna) domains support"
-url=" https://github.com/aio-libs/idna_ssl"
-arch="noarch"
-license="MIT"
-depends="py-idna"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$pkgname-$pkgver.tar.gz::https://github.com/aio-libs/$_pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-
-sha512sums="01e58e9f32f7e02ef203edbd76e199916ea0b16d01a929ca2fb272d83988483c17e9c36e131f47bfba7f7b657bef9e2be222f81800716a5b87d5847c27cce34d py-idna-ssl-1.1.0.tar.gz"
diff --git a/community/py3-idna-ssl/APKBUILD b/community/py3-idna-ssl/APKBUILD
new file mode 100644
index 0000000000..5a173c8057
--- /dev/null
+++ b/community/py3-idna-ssl/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-idna-ssl
+_pkgname=idna-ssl
+pkgver=1.1.0
+pkgrel=2
+pkgdesc="Patch ssl.match_hostname for Unicode(idna) domains support"
+url="https://github.com/aio-libs/idna-ssl"
+arch="noarch"
+license="MIT"
+depends="py3-idna"
+makedepends="py3-setuptools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/idna-ssl/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-idna-ssl # Backwards compatibility
+provides=py-idna-ssl=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="01e58e9f32f7e02ef203edbd76e199916ea0b16d01a929ca2fb272d83988483c17e9c36e131f47bfba7f7b657bef9e2be222f81800716a5b87d5847c27cce34d idna-ssl-1.1.0.tar.gz"