aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2016-01-19 22:07:41 -0800
committerTimo Teräs <timo.teras@iki.fi>2016-01-20 08:33:31 +0000
commita1001dc5198b6d7a15bf535060a5d88a7ffb40af (patch)
treedf510ec264c5242d38707a10315cfc5cab633695 /community
parent8c68262f6d9619eceb4ba3e573dce34318e3c3dd (diff)
downloadaports-a1001dc5198b6d7a15bf535060a5d88a7ffb40af.tar.bz2
aports-a1001dc5198b6d7a15bf535060a5d88a7ffb40af.tar.xz
community/xpdf: move from testing
It's been working well for quite a while.
Diffstat (limited to 'community')
-rw-r--r--community/xpdf/APKBUILD65
-rw-r--r--community/xpdf/xpdf-3.04-protection.patch84
-rw-r--r--community/xpdf/xpdfrc91
3 files changed, 240 insertions, 0 deletions
diff --git a/community/xpdf/APKBUILD b/community/xpdf/APKBUILD
new file mode 100644
index 0000000000..bb4ec6f3c0
--- /dev/null
+++ b/community/xpdf/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=xpdf
+pkgver="3.04"
+pkgrel=2
+pkgdesc="The classic X11 PDF viewer"
+url="http://foolabs.com/xpdf"
+arch="all"
+license="GPL2/GPL3"
+depends="ghostscript-fonts"
+depends_dev=""
+makedepends="motif-dev freetype-dev libpng-dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.foolabs.com/pub/xpdf/$pkgname-$pkgver.tar.gz
+ xpdf-3.04-protection.patch
+ xpdfrc"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ echo "$_builddir"
+ cd "$_builddir"
+ ./configure \
+ --with-x \
+ --with-freetype2-includes=/usr/include/freetype2 \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ #delete pdf* utils that conflict with poppler-utils.
+ rm -f "$pkgdir"/usr/bin/pdf*
+ rm -f "$pkgdir"/usr/share/man/man1/pdf*
+ #install xpdfrc so fonts get picked up
+ cp "$srcdir"/xpdfrc "$pkgdir"/etc/xpdfrc
+}
+
+md5sums="3bc86c69c8ff444db52461270bef3f44 xpdf-3.04.tar.gz
+11bd32802d9e600ad028f5b84194178d xpdf-3.04-protection.patch
+957ead33031ea7ddffe73e8af5658998 xpdfrc"
+sha256sums="11390c74733abcb262aaca4db68710f13ffffd42bfe2a0861a5dfc912b2977e5 xpdf-3.04.tar.gz
+5a12a1781eb29f83b3f0e3c1484e6c99537f84e42aa3dda9bb9c4a5befd83217 xpdf-3.04-protection.patch
+61177490dcfae9cb65af16486ab6567b81653f51f0279ee06a56516dd9a890d5 xpdfrc"
+sha512sums="3fb3c380fdbd13d937449ae3f7d7a163815cc85296d30be7b9907687884385d6171bb48ee5d5c13368d6bba87740b678f491bdcf61b38d130809e9afa260f6cf xpdf-3.04.tar.gz
+4c6360731ad60ed45e0612b016116a9588f293267ee3e2c1f7cd2f046f045f165334c6e7fceb6b51b3181adb7a74087036a28fcec0e04b23e6374ffc421c1f54 xpdf-3.04-protection.patch
+7e8404fa5432bad578c29cf3ccd276bb64cd0316b700e40ce606b6b6261c497125e8689c6e545cab2adb04d69b1ed25d1e0d07155add9837e6bb44d5f18d82d3 xpdfrc"
diff --git a/community/xpdf/xpdf-3.04-protection.patch b/community/xpdf/xpdf-3.04-protection.patch
new file mode 100644
index 0000000000..677db00095
--- /dev/null
+++ b/community/xpdf/xpdf-3.04-protection.patch
@@ -0,0 +1,84 @@
+Port Johannes Bauer's protection patch to 3.04.
+This does NOT disable the error messages, since the user should
+be aware of the author's intent.
+
+Also, this does not deal with permission to print.
+
+diff --git a/xpdf/PDFCore.cc b/xpdf/PDFCore.cc
+index 34b6483..e93fe52 100644
+--- a/xpdf/PDFCore.cc
++++ b/xpdf/PDFCore.cc
+@@ -1677,9 +1677,6 @@ GString *PDFCore::extractText(int pg, double xMin, double yMin,
+ int x0, y0, x1, y1, t;
+ GString *s;
+
+- if (!doc->okToCopy()) {
+- return NULL;
+- }
+ if ((page = findPage(pg))) {
+ cvtUserToDev(pg, xMin, yMin, &x0, &y0);
+ cvtUserToDev(pg, xMax, yMax, &x1, &y1);
+diff --git a/xpdf/XPDFCore.cc b/xpdf/XPDFCore.cc
+index 9a3725f..1562c7a 100644
+--- a/xpdf/XPDFCore.cc
++++ b/xpdf/XPDFCore.cc
+@@ -384,9 +384,8 @@ void XPDFCore::endSelection(int wx, int wy) {
+ #ifndef NO_TEXT_SELECT
+ if (selectULX != selectLRX &&
+ selectULY != selectLRY) {
+- if (doc->okToCopy()) {
+ copySelection();
+- } else {
++ if (!doc->okToCopy()) {
+ error(errNotAllowed, -1,
+ "Copying of text from this document is not allowed.");
+ }
+@@ -408,9 +407,6 @@ void XPDFCore::copySelection() {
+ int pg;
+ double ulx, uly, lrx, lry;
+
+- if (!doc->okToCopy()) {
+- return;
+- }
+ if (getSelection(&pg, &ulx, &uly, &lrx, &lry)) {
+ //~ for multithreading: need a mutex here
+ if (currentSelection) {
+diff --git a/xpdf/pdfimages.cc b/xpdf/pdfimages.cc
+index dc79443..9aaa811 100644
+--- a/xpdf/pdfimages.cc
++++ b/xpdf/pdfimages.cc
+@@ -122,8 +122,6 @@ int main(int argc, char *argv[]) {
+ if (!doc->okToCopy()) {
+ error(errNotAllowed, -1,
+ "Copying of images from this document is not allowed.");
+- exitCode = 3;
+- goto err1;
+ }
+
+ // get page range
+diff --git a/xpdf/pdftohtml.cc b/xpdf/pdftohtml.cc
+index f1fe691..824233e 100644
+--- a/xpdf/pdftohtml.cc
++++ b/xpdf/pdftohtml.cc
+@@ -134,8 +134,6 @@ int main(int argc, char *argv[]) {
+ if (!doc->okToCopy()) {
+ error(errNotAllowed, -1,
+ "Copying of text from this document is not allowed.");
+- exitCode = 3;
+- goto err1;
+ }
+
+ // get page range
+diff --git a/xpdf/pdftotext.cc b/xpdf/pdftotext.cc
+index 758413e..e6779fa 100644
+--- a/xpdf/pdftotext.cc
++++ b/xpdf/pdftotext.cc
+@@ -192,8 +192,6 @@ int main(int argc, char *argv[]) {
+ if (!doc->okToCopy()) {
+ error(errNotAllowed, -1,
+ "Copying of text from this document is not allowed.");
+- exitCode = 3;
+- goto err2;
+ }
+
+ // construct text file name
diff --git a/community/xpdf/xpdfrc b/community/xpdf/xpdfrc
new file mode 100644
index 0000000000..b51b522818
--- /dev/null
+++ b/community/xpdf/xpdfrc
@@ -0,0 +1,91 @@
+#========================================================================
+#
+# Sample xpdfrc file
+#
+# The Xpdf tools look for a config file in two places:
+# 1. ~/.xpdfrc
+# 2. in a system-wide directory, typically /usr/local/etc/xpdfrc
+#
+# This sample config file demonstrates some of the more common
+# configuration options. Everything here is commented out. You
+# should edit things (especially the file/directory paths, since
+# they'll likely be different on your system), and uncomment whichever
+# options you want to use. For complete details on config file syntax
+# and available options, please see the xpdfrc(5) man page.
+#
+# Also, the Xpdf language support packages each include a set of
+# options to be added to the xpdfrc file.
+#
+# http://www.foolabs.com/xpdf/
+#
+#========================================================================
+
+#----- display fonts
+
+# These map the Base-14 fonts to the Type 1 fonts that ship with
+# ghostscript. You'll almost certainly want to use something like
+# this, but you'll need to adjust this to point to wherever
+# ghostscript is installed on your system. (But if the fonts are
+# installed in a "standard" location, xpdf will find them
+# automatically.)
+
+fontFile Times-Roman /usr/share/fonts/Type1/n021003l.pfb
+fontFile Times-Italic /usr/share/fonts/Type1/n021023l.pfb
+fontFile Times-Bold /usr/share/fonts/Type1/n021004l.pfb
+fontFile Times-BoldItalic /usr/share/fonts/Type1/n021024l.pfb
+fontFile Helvetica /usr/share/fonts/Type1/n019003l.pfb
+fontFile Helvetica-Oblique /usr/share/fonts/Type1/n019023l.pfb
+fontFile Helvetica-Bold /usr/share/fonts/Type1/n019004l.pfb
+fontFile Helvetica-BoldOblique /usr/share/fonts/Type1/n019024l.pfb
+fontFile Courier /usr/share/fonts/Type1/n022003l.pfb
+fontFile Courier-Oblique /usr/share/fonts/Type1/n022023l.pfb
+fontFile Courier-Bold /usr/share/fonts/Type1/n022004l.pfb
+fontFile Courier-BoldOblique /usr/share/fonts/Type1/n022024l.pfb
+fontFile Symbol /usr/share/fonts/Type1/s050000l.pfb
+fontFile ZapfDingbats /usr/share/fonts/Type1/d050000l.pfb
+
+# If you need to display PDF files that refer to non-embedded fonts,
+# you should add one or more fontDir options to point to the
+# directories containing the font files. Xpdf will only look at .pfa,
+# .pfb, .ttf, and .ttc files in those directories (other files will
+# simply be ignored).
+
+#fontDir /usr/local/fonts/bakoma
+
+#----- PostScript output control
+
+# Set the default PostScript file or command.
+
+#psFile "|lpr -Pmyprinter"
+
+# Set the default PostScript paper size -- this can be letter, legal,
+# A4, or A3. You can also specify a paper size as width and height
+# (in points).
+
+psPaperSize letter
+
+#----- text output control
+
+# Choose a text encoding for copy-and-paste and for pdftotext output.
+# The Latin1, ASCII7, and UTF-8 encodings are built into Xpdf. Other
+# encodings are available in the language support packages.
+
+textEncoding UTF-8
+
+# Choose the end-of-line convention for multi-line copy-and-past and
+# for pdftotext output. The available options are unix, mac, and dos.
+
+#textEOL unix
+
+#----- misc settings
+
+# Enable FreeType, and anti-aliased text.
+
+enableFreeType yes
+antialias yes
+
+# Set the command used to run a web browser when a URL hyperlink is
+# clicked.
+
+#launchCommand viewer-script
+urlCommand "firefox '%s'"