aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-22 14:28:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-22 15:20:21 +0000
commitb46a3d4f3d260cbe26431d5da6bf5b1be3ba01f1 (patch)
treefe0950e9d679c5d05c3fd35aaf801a4493cdbfa4 /community
parenta91795a4c8120e1837aeb72307690b4b118ce313 (diff)
downloadaports-b46a3d4f3d260cbe26431d5da6bf5b1be3ba01f1.tar.bz2
aports-b46a3d4f3d260cbe26431d5da6bf5b1be3ba01f1.tar.xz
Revert "community/go: Fix the `cannot find runtime/cgo`-warning"
This change broke building of various packages, like docker and gomplate. This reverts commit 9686793792a2c40a872ebbb2b86fa537f22491ad.
Diffstat (limited to 'community')
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/go/default-buildmode-pie.patch21
2 files changed, 7 insertions, 18 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index b56cea3c00..7ad3e43f82 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=go
pkgver=1.11.2
-pkgrel=0
+pkgrel=1
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="all"
@@ -125,5 +125,5 @@ package() {
}
sha512sums="3d9b182718c7615975a4b47cecb9ff2a8ce62156461e4112452c14617ea226121e7ab736a469050f14c89861cc4934ddd2df295b80fffff0a2dd6c155eaf0aee go1.11.2.src.tar.gz
-effff60c1fb4ff18f1be1d34b4fa326a284b2197d0e9151223d19062dd315fde3d565ce2193aa53f7481c6542eb56daef834a3526957b65a275400f9af5d21b3 default-buildmode-pie.patch
+a8f3afd97992f03ccf2680cde214eefccac47daeb9eeb689b5e0b206ea3c19cfb23d448a4eb532894d830d4b91cd97b249e88f04c17feba02d9e243b40243bd0 default-buildmode-pie.patch
faf8de430df185842902322f064254f3e9ecee0884b3075b5550c85da15ff61ea6c2bb8d0fb7cf3887abc0e40974bd73ee8f8c14da7f914dde7e9220177c4e2a set-external-linker.patch"
diff --git a/community/go/default-buildmode-pie.patch b/community/go/default-buildmode-pie.patch
index 1924a483f2..3cf4865a78 100644
--- a/community/go/default-buildmode-pie.patch
+++ b/community/go/default-buildmode-pie.patch
@@ -1,19 +1,8 @@
-diff -upr go.orig/src/cmd/go/internal/load/pkg.go go/src/cmd/go/internal/load/pkg.go
---- go.orig/src/cmd/go/internal/load/pkg.go 2018-08-24 22:38:35.000000000 +0200
-+++ go/src/cmd/go/internal/load/pkg.go 2018-09-06 22:18:36.756408760 +0200
-@@ -1578,7 +1578,7 @@ func LinkerDeps(p *Package) []string {
- func externalLinkingForced(p *Package) bool {
- // Some targets must use external linking even inside GOROOT.
- switch cfg.BuildContext.GOOS {
-- case "android":
-+ case "android", "linux":
- return true
- case "darwin":
- switch cfg.BuildContext.GOARCH {
-diff -upr go.orig/src/cmd/go/internal/work/init.go go/src/cmd/go/internal/work/init.go
---- go.orig/src/cmd/go/internal/work/init.go 2018-08-24 22:38:35.000000000 +0200
-+++ go/src/cmd/go/internal/work/init.go 2018-09-06 22:18:03.942821296 +0200
-@@ -123,7 +123,8 @@ func buildModeInit() {
+diff --git a/src/cmd/go/internal/work/init.go b/src/cmd/go/internal/work/init.go
+index 7f894f5..a37cbf3 100644
+--- a/src/cmd/go/internal/work/init.go
++++ b/src/cmd/go/internal/work/init.go
+@@ -111,7 +111,8 @@ func buildModeInit() {
ldBuildmode = "c-shared"
case "default":
switch platform {