aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-21 14:49:00 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-21 14:49:54 +0100
commit405939ab84d740123a6f22071f9523b4a921d216 (patch)
tree46ff09f77bcada2c8bc83d1cdc26a84ec526daaf /community
parent8b2a8b1a32ded529a034ba70033dcf90aaf3f194 (diff)
downloadaports-405939ab84d740123a6f22071f9523b4a921d216.tar.bz2
aports-405939ab84d740123a6f22071f9523b4a921d216.tar.xz
community/rhash: improve abuild
Diffstat (limited to 'community')
-rw-r--r--community/rhash/APKBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/community/rhash/APKBUILD b/community/rhash/APKBUILD
index e90f6c7345..8eb99c7518 100644
--- a/community/rhash/APKBUILD
+++ b/community/rhash/APKBUILD
@@ -6,27 +6,19 @@ pkgdesc="Utility for calculation and verification of hash sums and magnet links"
url="http://rhash.anz.ru/"
arch="all"
license="custom"
-depends=
-depends_dev=""
-makedepends="$depends_dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-src.tar.gz
librhash-byte_order.h-Consult-also-compiler-s-predef.patch"
-
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make \
- || return 1
+ make
}
package() {
cd "$builddir"
- make install \
- DESTDIR="$pkgdir" \
- PREFIX=/usr \
- || return 1
+ make install DESTDIR="$pkgdir" PREFIX=/usr
}
md5sums="0b51010604659e9e99f6307b053ba13b rhash-1.3.4.tar.gz