aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-04 07:10:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-04 07:10:03 +0000
commite670079724e8ce2bc6742dfc088a14091f3f40f1 (patch)
treec9873849c626dfc8b58c9cc344252610a9091007 /community
parent799330f5e0d31faa66b6f745c668b46a8467eba3 (diff)
downloadaports-e670079724e8ce2bc6742dfc088a14091f3f40f1.tar.bz2
aports-e670079724e8ce2bc6742dfc088a14091f3f40f1.tar.xz
community/openblas: fix build on ppc64le
Diffstat (limited to 'community')
-rw-r--r--community/openblas/APKBUILD7
-rw-r--r--community/openblas/Use-the-old-zrot.S-assembly-on-POWER8-for-crot-as-well.patch23
2 files changed, 28 insertions, 2 deletions
diff --git a/community/openblas/APKBUILD b/community/openblas/APKBUILD
index 0258a880b2..c25c7108cd 100644
--- a/community/openblas/APKBUILD
+++ b/community/openblas/APKBUILD
@@ -13,7 +13,9 @@ depends=""
depends_dev="gfortran"
makedepends="$depends_dev perl linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/xianyi/$_pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xianyi/$_pkgname/archive/v$pkgver.tar.gz
+ Use-the-old-zrot.S-assembly-on-POWER8-for-crot-as-well.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
_builddir64="$builddir-64"
@@ -103,4 +105,5 @@ ilp64() {
mv "$pkgdir"/usr/lib/libopenblas64_* "$subpkgdir"/usr/lib/
}
-sha512sums="6a982d2adc13febc162d5c0077cedc116c771409ee1dbb651da6a073e5f6a439e1d0eba0349b3b2e506b274d3014adbf48fc96625ed942a61a54a0c936576b89 openblas-0.3.0.tar.gz"
+sha512sums="6a982d2adc13febc162d5c0077cedc116c771409ee1dbb651da6a073e5f6a439e1d0eba0349b3b2e506b274d3014adbf48fc96625ed942a61a54a0c936576b89 openblas-0.3.0.tar.gz
+db3e84388699dbb99c98f48e014fbb1175fb7d73b708b074555b4ce8927db3c4876047b908f191b40b69af9dfb8724a4907bc7ca9a9a1407ab4c85ebf7dc8914 Use-the-old-zrot.S-assembly-on-POWER8-for-crot-as-well.patch"
diff --git a/community/openblas/Use-the-old-zrot.S-assembly-on-POWER8-for-crot-as-well.patch b/community/openblas/Use-the-old-zrot.S-assembly-on-POWER8-for-crot-as-well.patch
new file mode 100644
index 0000000000..76247acccb
--- /dev/null
+++ b/community/openblas/Use-the-old-zrot.S-assembly-on-POWER8-for-crot-as-well.patch
@@ -0,0 +1,23 @@
+From 961d25e9c7e4a1758adb1dbeaa15187de69dd052 Mon Sep 17 00:00:00 2001
+From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
+Date: Wed, 23 May 2018 22:54:39 +0200
+Subject: [PATCH] Use the new zrot.c on POWER8 for crot as well
+
+fixes #1571 (the old zrot.S assembly does not handle incx=0 correctly)
+---
+ kernel/power/KERNEL.POWER8 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kernel/power/KERNEL.POWER8 b/kernel/power/KERNEL.POWER8
+index 00ff8682a..1aa061078 100644
+--- a/kernel/power/KERNEL.POWER8
++++ b/kernel/power/KERNEL.POWER8
+@@ -133,7 +133,7 @@ ZNRM2KERNEL = ../arm/znrm2.c
+ #
+ SROTKERNEL = srot.c
+ DROTKERNEL = drot.c
+-#CROTKERNEL = ../arm/zrot.c
++CROTKERNEL = zrot.c
+ ZROTKERNEL = zrot.c
+ #
+ SSCALKERNEL = sscal.c