aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2015-12-24 13:52:26 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2015-12-24 13:53:17 +0200
commit3a9c91b0974e5abd9f12421b864c55c1865d35af (patch)
treea6f90fbdeaba2134415f237b8e7ee3ee9d34ff67 /community
parenta3485e09fc6c2937b8cfc8812f49b0cc156f8caf (diff)
downloadaports-3a9c91b0974e5abd9f12421b864c55c1865d35af.tar.bz2
aports-3a9c91b0974e5abd9f12421b864c55c1865d35af.tar.xz
community/dovecot-pigeonhole-plugin: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/dovecot-pigeonhole-plugin/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/dovecot-pigeonhole-plugin/APKBUILD b/community/dovecot-pigeonhole-plugin/APKBUILD
new file mode 100644
index 0000000000..e46330da18
--- /dev/null
+++ b/community/dovecot-pigeonhole-plugin/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Kozak Ivan <kozak-iv@yandex.ru>
+# Maintainer: Kozak Ivan <kozak-iv@yandex.ru>
+pkgname=dovecot-pigeonhole-plugin
+_realname=dovecot-2.2-pigeonhole
+pkgver=0.4.10
+pkgrel=0
+pkgdesc="Pigeonhole project provides Sieve support as a plugin to Dovecot's LDA"
+url="http://pigeonhole.dovecot.org"
+arch="all"
+license="LGPL"
+depends="dovecot"
+depends_dev=""
+makedepends="dovecot-dev openssl-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-dev $pkgname-tools"
+source="http://pigeonhole.dovecot.org/releases/2.2/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-dovecot=/usr/lib/dovecot \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ pkgdesc="Pigeonhole project provides Sieve support (test and debug tools)"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="a11632e1302d2d906267d67e761da218 dovecot-2.2-pigeonhole-0.4.10.tar.gz"
+sha256sums="e9dfe7160fd3b465d6d5068f219122626ef790cce507e290cd09852c7d90726f dovecot-2.2-pigeonhole-0.4.10.tar.gz"
+sha512sums="3e864727fc2bd346a7212135a3dd8759f9a5c27abd938c4d6b805c784c5c2c5aa401dd49cfa90951348a00202b85f91d86a2fa17ccab9a983a6faf2d0add48e8 dovecot-2.2-pigeonhole-0.4.10.tar.gz"