aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-25 21:56:37 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-25 21:56:37 +0200
commit88e0a85bf7c1ad471caaf6347497aebaff7b1cf2 (patch)
tree09debd41372782cf596091a2bdbb128d70910fb9 /community
parentde0bc2f456d65302a71ae8557947686b245db8eb (diff)
downloadaports-88e0a85bf7c1ad471caaf6347497aebaff7b1cf2.tar.bz2
aports-88e0a85bf7c1ad471caaf6347497aebaff7b1cf2.tar.xz
community/lua-copas: disable check on ppc64le LuaJIT for now
>>> lua-copas*: Testing on luajit luajit -e "package.path='src/?.lua;'..package.path" tests/largetransfer.lua starting loop Segmentation fault make: *** [Makefile:25: test] Error 139 >>> ERROR: lua-copas*: check failed
Diffstat (limited to 'community')
-rw-r--r--community/lua-copas/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/lua-copas/APKBUILD b/community/lua-copas/APKBUILD
index 5133086bb7..5bdccd9cdc 100644
--- a/community/lua-copas/APKBUILD
+++ b/community/lua-copas/APKBUILD
@@ -16,8 +16,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/arch
builddir="$srcdir/$_pkgname-$_pkgver"
# luajit is not available on s390x
+# XXX: tests/largetransfer.lua segfaults on ppc64le LuaJIT
case "$CARCH" in
- s390x) _luajit="";;
+ s390x | ppc64le) _luajit="";;
*) checkdepends="$checkdepends luajit" _luajit="jit";;
esac