aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-05-18 11:54:04 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-16 13:20:12 +0000
commitdca0d6e33e0aa22eda936daea8eb43b3e4ece412 (patch)
treeb95f7b458688e4c6c2abaafdfaea2bc58df1870c /community
parent81f614634df220f2f45efbdefd4efe1c47360891 (diff)
downloadaports-dca0d6e33e0aa22eda936daea8eb43b3e4ece412.tar.bz2
aports-dca0d6e33e0aa22eda936daea8eb43b3e4ece412.tar.xz
community/rippled: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/rippled/APKBUILD38
-rw-r--r--community/rippled/musl-fixes.patch49
2 files changed, 87 insertions, 0 deletions
diff --git a/community/rippled/APKBUILD b/community/rippled/APKBUILD
new file mode 100644
index 0000000000..2120cbbfd0
--- /dev/null
+++ b/community/rippled/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=rippled
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Blockchain daemon implementing the Ripple Consensus Ledger"
+url="https://ripple.com/"
+arch="x86_64"
+license="ISC"
+makedepends="cmake libressl-dev boost-dev protobuf-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ripple/$pkgname/archive/$pkgver.tar.gz
+ musl-fixes.patch
+ "
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=release
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./build/rippled --unittest
+}
+
+package() {
+ cd "$builddir"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -D build/rippled "${pkgdir}/usr/bin/rippled"
+ install -D -m644 cfg/rippled-example.cfg "${pkgdir}/etc/$pkgname/rippled.cfg"
+ install -D -m644 cfg/validators-example.txt "${pkgdir}/etc/$pkgname/validators.txt"
+}
+
+sha512sums="13819b7c2718178a07487a32f78598862dd2b91d1a95237912cb40c56acf4b8a8ea5bf771414bdf4871c81e2856610c7feb6cf37be8fff9a08fce60c0a1e9ce8 rippled-1.0.0.tar.gz
+fb063fa49278a5ffbe3fb3f2c348e83f0b936bc35cab181ef02575f4a3a2ad08997dad970b101b5d9796706757e29cd1d1546da1b550e875be08d01c7e31ef16 musl-fixes.patch"
diff --git a/community/rippled/musl-fixes.patch b/community/rippled/musl-fixes.patch
new file mode 100644
index 0000000000..c7615d7e1d
--- /dev/null
+++ b/community/rippled/musl-fixes.patch
@@ -0,0 +1,49 @@
+diff --git a/src/ripple/basics/StringUtilities.h b/src/ripple/basics/StringUtilities.h
+index f4cc83f..d2aa4bd 100644
+--- a/src/ripple/basics/StringUtilities.h
++++ b/src/ripple/basics/StringUtilities.h
+@@ -26,6 +26,7 @@
+ #include <boost/format.hpp>
+ #include <sstream>
+ #include <string>
++#include <endian.h>
+
+ namespace ripple {
+
+diff --git a/src/ripple/basics/base_uint.h b/src/ripple/basics/base_uint.h
+index cfa6867..1ce4ec3 100644
+--- a/src/ripple/basics/base_uint.h
++++ b/src/ripple/basics/base_uint.h
+@@ -31,6 +31,7 @@
+ #include <ripple/basics/hardened_hash.h>
+ #include <ripple/beast/utility/Zero.h>
+ #include <boost/functional/hash.hpp>
++#include <endian.h>
+ #include <functional>
+ #include <type_traits>
+
+diff --git a/src/rocksdb2/util/log_buffer.h b/src/rocksdb2/util/log_buffer.h
+index 2a24bf8..ddaaa2c 100644
+--- a/src/rocksdb2/util/log_buffer.h
++++ b/src/rocksdb2/util/log_buffer.h
+@@ -9,6 +9,7 @@
+ #include "util/arena.h"
+ #include "util/autovector.h"
+ #include <ctime>
++#include <sys/time.h>
+
+ namespace rocksdb {
+
+diff --git a/src/ripple/beast/core/core.unity.cpp b/src/ripple/beast/core/core.unity.cpp
+index 83dd1df..b374634 100644
+--- a/src/ripple/beast/core/core.unity.cpp
++++ b/src/ripple/beast/core/core.unity.cpp
+@@ -113,7 +113,7 @@
+ #include <net/if.h>
+ #include <sys/ioctl.h>
+
+- #if ! BEAST_ANDROID && ! BEAST_BSD
++ #if ! BEAST_ANDROID && ! BEAST_BSD && 0
+ #include <execinfo.h>
+ #endif
+ #endif