aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorGeod24 <pro.mathias.lang@gmail.com>2020-03-02 22:34:34 +0900
committerRasmus Thomsen <oss@cogitri.dev>2020-03-02 15:45:53 +0100
commit09f535dbeec476116d9b94193a4306671ff07e4b (patch)
tree7b8ba7dd77e465dd3d3404b9fead51ab5d9791e4 /community
parentcd7fd733581bbc264431a3d3fbce04fae44f9962 (diff)
downloadaports-09f535dbeec476116d9b94193a4306671ff07e4b.tar.bz2
aports-09f535dbeec476116d9b94193a4306671ff07e4b.tar.xz
community/dtools: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/dtools/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/community/dtools/APKBUILD b/community/dtools/APKBUILD
new file mode 100644
index 0000000000..635e5ad1c2
--- /dev/null
+++ b/community/dtools/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Mathias LANG <pro.mathias.lang@gmail.com>
+# Maintainer: Mathias LANG <pro.mathias.lang@gmail.com>
+#
+# There are 4 'public' tools in the repository as of v2.090.1
+# In addition, there are a few 'build' tools which could be
+# useful (and can be trivially added if needed).
+#
+# Out of those 4 public tools, only 'dman' has heavy dependencies,
+# as it rely on building dlang.org (and by extension DMD & co),
+# so it is excluded from this package.
+pkgname=dtools
+pkgver=2.090.1
+pkgrel=0
+pkgdesc="Ancillary tools for the D programming language compiler"
+url="https://github.com/dlang/tools"
+arch="x86_64"
+license="BSL-1.0"
+makedepends="ldc"
+subpackages="$pkgname-ddemangle $pkgname-rdmd"
+source="tools-$pkgver.tar.gz::https://github.com/dlang/tools/archive/v$pkgver.tar.gz"
+builddir="$srcdir/tools-$pkgver/"
+_outputdir="$builddir/alpine-build/"
+
+build() {
+ ldmd2 -O -release "$builddir/ddemangle.d" -of"$_outputdir/ddemangle"
+ ldmd2 -O -release "$builddir/DustMite/dustmite.d" "$builddir/DustMite/splitter.d" -of"$_outputdir/dustmite"
+ ldmd2 -O -release "$builddir/rdmd.d" -of"$_outputdir/rdmd"
+}
+
+check() {
+ ldmd2 -run "$builddir/rdmd_test.d" --rdmd-default-compiler=ldmd2 "$_outputdir/rdmd"
+}
+
+package() {
+ depends="$pkgname-ddemangle $pkgname-dustmite $pkgname-rdmd"
+
+ install -s -D "$_outputdir/ddemangle" "$pkgdir/usr/bin/ddemangle"
+ install -s -D "$_outputdir/dustmite" "$pkgdir/usr/bin/dustmite"
+ install -s -D "$_outputdir/rdmd" "$pkgdir/usr/bin/rdmd"
+}
+
+ddemangle() {
+ mkdir -p "$subpkgdir/usr/bin/"
+ mv "$pkgdir/usr/bin/ddemangle" "$subpkgdir/usr/bin/ddemangle"
+}
+
+dustmite() {
+ mkdir -p "$subpkgdir/usr/bin/"
+ mv "$pkgdir/usr/bin/dustmite" "$subpkgdir/usr/bin/dustmite"
+}
+
+rdmd() {
+ mkdir -p "$subpkgdir/usr/bin/"
+ mv "$pkgdir/usr/bin/rdmd" "$subpkgdir/usr/bin/rdmd"
+}
+
+sha512sums="82f6d3fd4a7f6fd013425894ec5f817c960764479649c97139a019802fc5c2a83671102f1b2a9427e88446055e5a1a4fa884a4b86400a84107b2d5ca322b7a32 tools-2.090.1.tar.gz"