aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-30 19:03:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-03 14:36:09 +0000
commit378bf1e77ba94a1a1d6f68c694b35a80defe2e30 (patch)
treebc403686bea8f35199ec393d42cc90be89a45c12 /community
parentbfc07bdc202dd99449f16ecdaf852a03ba8e7fd6 (diff)
downloadaports-378bf1e77ba94a1a1d6f68c694b35a80defe2e30.tar.bz2
aports-378bf1e77ba94a1a1d6f68c694b35a80defe2e30.tar.xz
community/py3-email-validator: upgrade to 1.1.0
Diffstat (limited to 'community')
-rw-r--r--community/py3-email-validator/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/py3-email-validator/APKBUILD b/community/py3-email-validator/APKBUILD
index 44a1513e54..23df79b6ec 100644
--- a/community/py3-email-validator/APKBUILD
+++ b/community/py3-email-validator/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=py3-email-validator
_pkgname=python-email-validator
-pkgver=1.0.5
-pkgrel=1
+pkgver=1.1.0
+pkgrel=0
pkgdesc="A robust email syntax and deliverability validation library"
-url=https://github.com/JoshData/python-email-validator
+url="https://github.com/JoshData/python-email-validator"
arch="noarch"
license="CC0-1.0"
depends="py3-dnspython py3-idna"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/JoshData/$_pkgname/archive/v$pkgver.tar.gz"
builddir=$srcdir/$_pkgname-$pkgver
@@ -20,12 +21,11 @@ build() {
}
check() {
- python3 -c "import email_validator; email_validator.main()" \
- --tests < test_pass.txt
+ PYTHONPATH="$PWD/build/lib" py.test-3
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="e9dd0ee8dfc603e40591eb8cd4e58c32331c1b9450feb4ae0ff27e1d655d0abb2c8a46b7d0cb43d7e037964f0c120dbad6bf32a60dfe297fb552058733ffd173 py3-email-validator-1.0.5.tar.gz"
+sha512sums="9eb3636298dcfc71aa2dada3e10044966181d1a6e5f7cd397a3143c82a855760cf69b129b573f01d75702b96f78da9a9799350bdf6eb8f12cfd7daa013e71604 py3-email-validator-1.1.0.tar.gz"