aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:30:54 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:48:06 +0200
commit51fdc6b25238622ecfb5c29d4a139bd1c4c0efeb (patch)
tree7025b7a10162cf4d38944d6f2a767cb3a027d957 /community
parente9457d3216f02fcbfd50290c059d5be8b78e0d87 (diff)
downloadaports-51fdc6b25238622ecfb5c29d4a139bd1c4c0efeb.tar.bz2
aports-51fdc6b25238622ecfb5c29d4a139bd1c4c0efeb.tar.xz
community/caribou: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/caribou/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/caribou/APKBUILD b/community/caribou/APKBUILD
new file mode 100644
index 0000000000..230cefc6bd
--- /dev/null
+++ b/community/caribou/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer:
+pkgname=caribou
+pkgver=0.4.21
+pkgrel=2
+pkgdesc="on screen keyboard implementation"
+url="https://wiki.gnome.org/Projects/Caribou"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="gtk+2.0-dev gtk+3.0-dev py-gobject3-dev clutter-dev libxklavier-dev libgee-dev libxml2-dev"
+makedepends="$depends_dev intltool itstool libxml2-utils libxslt py-gobject3"
+install=""
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://download.gnome.org/sources/caribou/${pkgver%.*}/caribou-$pkgver.tar.xz"
+builddir="$srcdir/caribou-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5fc0cf54a1cad50d41e659adbbb932b51d69d18951562f87497e99aaae17ac72b453b759dd7289ff8f68a79574dfce510b9de6bedc61408c14cb48b83eaf08da caribou-0.4.21.tar.xz"