aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-30 14:32:46 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-30 17:10:01 +0100
commit560153519b4ef905309993a932672bded3052287 (patch)
tree19247c22394d52ae95e9ec3108405c2fc6c2a5c5 /community
parent893e57bc70158d7804a78c32724775f4a6c9a04f (diff)
downloadaports-560153519b4ef905309993a932672bded3052287.tar.bz2
aports-560153519b4ef905309993a932672bded3052287.tar.xz
community/telepathy-farstream: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/telepathy-farstream/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/telepathy-farstream/APKBUILD b/community/telepathy-farstream/APKBUILD
new file mode 100644
index 0000000000..78d78b0cdf
--- /dev/null
+++ b/community/telepathy-farstream/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Git version to support Python 3, not needed when 0.6.3 or 0.7.0 is released
+pkgname=telepathy-farstream
+pkgver=0.6.2_git20190919
+pkgrel=0
+_commit="c7299b4ef37726155a7fcb7ebbdb9786c1e9e81e"
+pkgdesc="Telepathy GLib-based client library that uses Farstream to handle Call channels"
+arch="all"
+url="https://telepathy.freedesktop.org/components/telepathy-farstream/"
+license="LGPL-2.1-or-later"
+depends_dev="dbus-glib-dev telepathy-glib-dev gobject-introspection-dev"
+makedepends="$depends_dev autoconf automake gtk-doc python3 farstream-dev"
+source="$pkgname-$_commit.tar.gz::https://github.com/TelepathyIM/telepathy-farstream/archive/$_commit.tar.gz"
+#source="https://github.com/TelepathyIM/telepathy-farstream/archive/telepathy-farstream-$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+builddir="$srcdir/$pkgname-$_commit"
+
+prepare() {
+ default_prepare
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/telepathy \
+ --disable-static \
+ --enable-gtk-doc \
+ --disable-Werror # Should be enabled again in next release
+
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="7387832d8d9afbcc87774ee16025842940b4fab979e492e1301734a37777120241d4b06dd2f6ee6743e68783967de73129dcd3fb41ff3d1be0aa1c6c0c44eb3a telepathy-farstream-c7299b4ef37726155a7fcb7ebbdb9786c1e9e81e.tar.gz"