aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-10 16:32:17 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-10 16:33:51 +0100
commit618e500f6568073391ed9a115ca644e7cb271572 (patch)
tree22d4d7131b087252a2c2bc8a26afcf51636b0b70 /community
parentd03f0cb98fed8d511bbfa1ce58f78e6980aaaaf4 (diff)
downloadaports-618e500f6568073391ed9a115ca644e7cb271572.tar.bz2
aports-618e500f6568073391ed9a115ca644e7cb271572.tar.xz
community/ttf-roboto: move from testing
Required by adapta-gtk-theme
Diffstat (limited to 'community')
-rw-r--r--community/ttf-roboto/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/ttf-roboto/APKBUILD b/community/ttf-roboto/APKBUILD
new file mode 100644
index 0000000000..e5a3a64332
--- /dev/null
+++ b/community/ttf-roboto/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=ttf-roboto
+pkgver=2.138
+pkgrel=0
+pkgdesc="The Roboto family of fonts"
+options="!check" # No testsuite
+url="https://github.com/google/roboto"
+arch="noarch"
+depends="fontconfig"
+license="Apache-2.0"
+source="$pkgname-$pkgver.tar.gz::https://github.com/google/roboto/archive/v$pkgver.tar.gz"
+builddir="$srcdir/roboto-$pkgver"
+
+package() {
+ install -d "$pkgdir"/usr/share/fonts/TTF
+ find . -type f -name '*.ttf' | while read -r font; do
+ install -Dm644 "$font" -t "$pkgdir"/usr/share/fonts/TTF
+ done
+}
+
+sha512sums="f4bec4bd76745a625a946c98d52222d49e93e5480d9f25913ec2456dbd9252a07e4864eba98a8bb6ca724994fd82e7c8d91384ea315d028703e9a0e0b1df1446 ttf-roboto-2.138.tar.gz"