aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-04-15 14:20:04 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-15 20:39:02 +0000
commit6c85b846a979f8c9acdac5d550364f6e30332214 (patch)
treefb62402134877db46b1f0911439567eebe386727 /community
parent218d3d968698a2611c86431bad9059ec9bc8e4e7 (diff)
downloadaports-6c85b846a979f8c9acdac5d550364f6e30332214.tar.bz2
aports-6c85b846a979f8c9acdac5d550364f6e30332214.tar.xz
community/iwd: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/iwd/APKBUILD51
-rw-r--r--community/iwd/dbus-netdev-group.patch14
-rw-r--r--community/iwd/iwd.initd13
3 files changed, 78 insertions, 0 deletions
diff --git a/community/iwd/APKBUILD b/community/iwd/APKBUILD
new file mode 100644
index 0000000000..df03bcc0ea
--- /dev/null
+++ b/community/iwd/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=iwd
+pkgver=0.14
+pkgrel=3
+pkgdesc="Internet Wireless Daemon"
+url="https://iwd.wiki.kernel.org/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="ell-dev dbus-dev readline-dev linux-headers asciidoc"
+subpackages="$pkgname-doc $pkgname-openrc"
+source="https://mirrors.edge.kernel.org/pub/linux/network/wireless/$pkgname-${pkgver}.tar.gz
+ dbus-netdev-group.patch
+ iwd.initd
+ "
+builddir="$srcdir/$pkgname-${pkgver}"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-external-ell \
+ --disable-systemd-service \
+ --enable-sim-hardcoded \
+ --enable-tools \
+ --enable-docs
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -m750 -d "$pkgdir"/var/lib/$pkgname
+ install -Dm644 doc/main.conf "$pkgdir"/etc/"$pkgname"/main.conf
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+}
+
+sha512sums="aa4586611d6c7298f9b00fe1de88b83157f037e76c7f01d8c3df8e21d7d6796ce3551be9764681a412bf147e741ff65469adaa6da4d96bdc4e2667059202b656 iwd-0.14.tar.gz
+7d3bc26b558ebfd22335b946f09abd5326e885275979c617af7def1468ade23ba7605f3b13aaf91836035c130aaec04be0ff2708a898f3ae835e0eef4e78fa0e dbus-netdev-group.patch
+1a913fa19a76a18d92b8f44cb5b4b99a64b4e2f7d2b4a486bf1ba2f939aea7dcca772fca91483011ada58aaa3addc29c76ececd708b2187e57f72aa040ac77e6 iwd.initd"
diff --git a/community/iwd/dbus-netdev-group.patch b/community/iwd/dbus-netdev-group.patch
new file mode 100644
index 0000000000..4b72ba45d3
--- /dev/null
+++ b/community/iwd/dbus-netdev-group.patch
@@ -0,0 +1,14 @@
+--- a/src/iwd-dbus.conf 2018-09-20 19:43:09.000000000 +0200
++++ b/src/iwd-dbus.conf 2018-09-20 21:02:03.000000000 +0100
+@@ -18,6 +18,11 @@
+ <allow send_interface="net.connman.iwd.Agent"/>
+ </policy>
+
++ <policy group="netdev">
++ <allow send_destination="net.connman.iwd"/>
++ <allow send_interface="net.connman.iwd.Agent"/>
++ </policy>
++
+ <policy at_console="true">
+ <allow send_destination="net.connman.iwd"/>
+ <allow send_interface="net.connman.iwd.Agent"/>
diff --git a/community/iwd/iwd.initd b/community/iwd/iwd.initd
new file mode 100644
index 0000000000..3ae8fc436a
--- /dev/null
+++ b/community/iwd/iwd.initd
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/run/iwd.pid"
+command="/usr/libexec/iwd"
+command_background="yes"
+
+depend() {
+ need dbus
+ before net
+ keyword -shutdown
+}