aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-12-14 08:50:17 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-14 08:51:26 +0000
commit6eb6ef1b6a1e924c0e82564dbc61475a8bc5e8d5 (patch)
treeb045607052dfc3a68b85fc5c1da4d73a7ca402f3 /community
parentca93d24a0026cfc1cac5229df60475ce936cf5ba (diff)
downloadaports-6eb6ef1b6a1e924c0e82564dbc61475a8bc5e8d5.tar.bz2
aports-6eb6ef1b6a1e924c0e82564dbc61475a8bc5e8d5.tar.xz
community/backuppc: no longer maintained
Diffstat (limited to 'community')
-rw-r--r--community/backuppc/APKBUILD79
-rw-r--r--community/backuppc/backuppc.initd26
-rw-r--r--community/backuppc/backuppc.pre-install6
-rw-r--r--community/backuppc/configure.pl.patch69
-rw-r--r--community/backuppc/fix-pidfile-path.patch35
-rw-r--r--community/backuppc/fix-socket-path.patch22
-rw-r--r--community/backuppc/remove-deprecated-perl-defined-at.patch23
7 files changed, 260 insertions, 0 deletions
diff --git a/community/backuppc/APKBUILD b/community/backuppc/APKBUILD
new file mode 100644
index 0000000000..30ac1c0955
--- /dev/null
+++ b/community/backuppc/APKBUILD
@@ -0,0 +1,79 @@
+# Contributor:
+pkgname="backuppc"
+_realname="BackupPC"
+pkgver=3.3.2
+pkgrel=0
+pkgdesc="High-performance, enterprise-grade backup system"
+url="http://backuppc.sourceforge.net/"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="perl busybox rsync perl-archive-zip perl-io-compress
+ perl-libwww perl-file-rsync samba-client"
+pkgusers="backuppc"
+pkggroups="backuppc"
+install="$pkgname.pre-install"
+source="https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$_realname-$pkgver.tar.gz
+ $pkgname.initd
+
+ configure.pl.patch
+ fix-pidfile-path.patch
+ fix-socket-path.patch
+ "
+builddir="$srcdir/$_realname-$pkgver"
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/etc/BackupPC \
+ "$pkgdir"/var/www/cgi-bin \
+ "$pkgdir"/var/www/htdocs/BackupPC || return 1
+
+ perl configure.pl \
+ --batch \
+ --backuppc-user=backuppc \
+ --bin-path bzip2=/usr/bin/bzip2 \
+ --bin-path cat=/bin/cat \
+ --bin-path df=/bin/df \
+ --bin-path tar=/bin/tar \
+ --bin-path hostname=/bin/hostname \
+ --bin-path nmblookup=/usr/bin/nmblookup \
+ --bin-path perl=/usr/bin/perl \
+ --bin-path ping=/bin/ping \
+ --bin-path rsync=/usr/bin/rsync \
+ --bin-path sendmail=/usr/sbin/sendmail \
+ --bin-path smbclient=/usr/bin/smbclient \
+ --bin-path split=/usr/bin/split \
+ --bin-path ssh=/usr/bin/ssh \
+ --compress-level=3 \
+ --dest-dir="$pkgdir" \
+ --config-dir /etc/BackupPC \
+ --cgi-dir /var/www/cgi-bin \
+ --data-dir /var/lib/BackupPC \
+ --hostname backuppc \
+ --html-dir /var/www/htdocs/BackupPC \
+ --html-dir-url /BackupPC \
+ --install-dir /usr/share/BackupPC \
+ --log-dir /var/log/BackupPC \
+ --uid-ignore \
+ --no-set-perms || return 1
+
+ install -m755 configure.pl \
+ "$pkgdir"/usr/share/BackupPC/bin/configure.pl || return 1
+ install -D -m755 "$srcdir"/backuppc.initd \
+ "$pkgdir"/etc/init.d/backuppc || return 1
+
+ chmod 775 "$pkgdir"/usr/share/BackupPC/bin/*
+
+ local dir; for dir in etc var/log var/lib; do
+ chown -R backuppc:backuppc "$pkgdir"/$dir/BackupPC || return 1
+ chmod 755 "$pkgdir"/$dir || return 1
+ done
+
+ ln -s /var/www/cgi-bin/BackupPC_Admin "$pkgdir"/var/www/htdocs/index.cgi || return 1
+}
+
+sha512sums="26176398cc619be05f864b56cb1d259f5eb6814bbe0fd30bd1527f6705dff175999c2b4e8a8767db0c5e0826065788f17d3ccdb5dbb608b62a7f56035fdc052b BackupPC-3.3.2.tar.gz
+a38361fd0e54a4c0100a7bf94b09483e5ba246dc45d6955d275542dd5662d8da11d9580685195b7d4dfa9a07c0487a52a14a95340737e70889ffe5c5e26d5ff8 configure.pl.patch
+15fdb58e038160775fe4deebf6c8adbc128a37da2a866ef00e1eea202c396220cdd1c0547a45f11127dbdc957eaed5188cb87a05467d25647fb462be28c51ce7 fix-pidfile-path.patch
+4391bdfaa3044a4eecec617fbcba1bf21bdd9389e3d3a73f62e74e6b818de40fc1600e26b358cf35a6bac01086ed12a3ff7abba64e67d11c7a91b2046c239189 fix-socket-path.patch
+288bba10ca4dd585638625321395e0a40aca30169a122c443f7c6fcd55143e6fcdfa5d39595bacf06cc4960b6e17992a57ec3d3a7ddd9b140e44da4ebdd019d3 backuppc.initd"
diff --git a/community/backuppc/backuppc.initd b/community/backuppc/backuppc.initd
new file mode 100644
index 0000000000..751f04bf4e
--- /dev/null
+++ b/community/backuppc/backuppc.initd
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+
+extra_started_commands="reload"
+
+: ${user:="backuppc"}
+: ${logdir:="/var/log/BackupPC"}
+: ${command_args:="-d"}
+
+command="/usr/share/BackupPC/bin/BackupPC"
+start_stop_daemon_args="--interpreted --user $user"
+pidfile="/run/BackupPC/BackupPC.pid"
+retry="30"
+
+depend() {
+ after firewall modules
+}
+
+start_pre() {
+ checkpath -d -o $user -m 755 "${pidfile%/*}"
+}
+
+reload() {
+ ebegin "Reloading $name"
+ start-stop-daemon --signal 1 --pidfile "$pidfile" -x /usr/bin/perl
+ eend $?
+}
diff --git a/community/backuppc/backuppc.pre-install b/community/backuppc/backuppc.pre-install
new file mode 100644
index 0000000000..eea66968c1
--- /dev/null
+++ b/community/backuppc/backuppc.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S backuppc 2>/dev/null
+adduser -S -D -H -h /var/lib/BackupPC -s /bin/sh -G backuppc -g "BackupPC user" backuppc 2>/dev/null
+
+exit 0
diff --git a/community/backuppc/configure.pl.patch b/community/backuppc/configure.pl.patch
new file mode 100644
index 0000000000..67c2892ab4
--- /dev/null
+++ b/community/backuppc/configure.pl.patch
@@ -0,0 +1,69 @@
+--- BackupPC-3.3.0.orig/configure.pl
++++ BackupPC-3.3.0/configure.pl
+@@ -327,25 +327,11 @@
+
+ EOF
+ my($name, $passwd, $Uid, $Gid);
+-while ( 1 ) {
+- $Conf{BackupPCUser} = prompt("--> BackupPC should run as user",
+- $Conf{BackupPCUser} || "backuppc",
+- "backuppc-user");
+- if ( $opts{"set-perms"} ) {
++ $Conf{BackupPCUser} = prompt("--> BackupPC should run as user",
++ $Conf{BackupPCUser} || "backuppc",
++ "backuppc-user");
+ ($name, $passwd, $Uid, $Gid) = getpwnam($Conf{BackupPCUser});
+- last if ( $name ne "" );
+- print <<EOF;
+
+-getpwnam() says that user $Conf{BackupPCUser} doesn't exist. Please
+-check the name and verify that this user is in the passwd file.
+-
+-EOF
+- exit(1) if ( $opts{batch} );
+- } else {
+- last;
+- }
+-}
+-
+ print <<EOF;
+
+ Please specify an install directory for BackupPC. This is where the
+@@ -532,12 +518,6 @@
+ ) ) {
+ next if ( -d "$DestDir$Conf{InstallDir}/$dir" );
+ mkpath("$DestDir$Conf{InstallDir}/$dir", 0, 0755);
+- if ( !-d "$DestDir$Conf{InstallDir}/$dir"
+- || !my_chown($Uid, $Gid, "$DestDir$Conf{InstallDir}/$dir") ) {
+- die("Failed to create or chown $DestDir$Conf{InstallDir}/$dir\n");
+- } else {
+- print("Created $DestDir$Conf{InstallDir}/$dir\n");
+- }
+ }
+
+ #
+@@ -546,11 +526,6 @@
+ foreach my $dir ( ($Conf{CgiImageDir}) ) {
+ next if ( $dir eq "" || -d "$DestDir$dir" );
+ mkpath("$DestDir$dir", 0, 0755);
+- if ( !-d "$DestDir$dir" || !my_chown($Uid, $Gid, "$DestDir$dir") ) {
+- die("Failed to create or chown $DestDir$dir");
+- } else {
+- print("Created $DestDir$dir\n");
+- }
+ }
+
+ #
+@@ -566,12 +541,6 @@
+ "$Conf{LogDir}",
+ ) ) {
+ mkpath("$DestDir$dir", 0, 0750) if ( !-d "$DestDir$dir" );
+- if ( !-d "$DestDir$dir"
+- || !my_chown($Uid, $Gid, "$DestDir$dir") ) {
+- die("Failed to create or chown $DestDir$dir\n");
+- } else {
+- print("Created $DestDir$dir\n");
+- }
+ }
+
+ printf("Installing binaries in $DestDir$Conf{InstallDir}/bin\n");
diff --git a/community/backuppc/fix-pidfile-path.patch b/community/backuppc/fix-pidfile-path.patch
new file mode 100644
index 0000000000..ad76a53961
--- /dev/null
+++ b/community/backuppc/fix-pidfile-path.patch
@@ -0,0 +1,35 @@
+--- a/bin/BackupPC
++++ b/bin/BackupPC
+@@ -363,11 +363,11 @@
+ # Write out our initial status and save our PID
+ #
+ StatusWrite();
+- unlink("$LogDir/BackupPC.pid");
+- if ( open(PID, ">", "$LogDir/BackupPC.pid") ) {
++ unlink("/run/backuppc/BackupPC.pid");
++ if ( open(PID, ">", "/run/backuppc/BackupPC.pid") ) {
+ print(PID $$);
+ close(PID);
+- chmod(0444, "$LogDir/BackupPC.pid");
++ chmod(0444, "/run/backuppc/BackupPC.pid");
+ }
+
+ #
+@@ -1846,7 +1846,7 @@
+ close(LOG);
+ LogFileOpen();
+ print(LOG "Fatal error: unhandled signal $SigName\n");
+- unlink("$LogDir/BackupPC.pid");
++ unlink("/run/backuppc/BackupPC.pid");
+ confess("Got new signal $SigName... quitting\n");
+ } else {
+ $SigName = shift;
+@@ -1968,7 +1968,7 @@
+ }
+ delete($Info{pid});
+ StatusWrite();
+- unlink("$LogDir/BackupPC.pid");
++ unlink("/run/backuppc/BackupPC.pid");
+ exit(1);
+ }
+
diff --git a/community/backuppc/fix-socket-path.patch b/community/backuppc/fix-socket-path.patch
new file mode 100644
index 0000000000..ebc582fa26
--- /dev/null
+++ b/community/backuppc/fix-socket-path.patch
@@ -0,0 +1,22 @@
+--- a/bin/BackupPC
++++ b/bin/BackupPC
+@@ -1885,7 +1885,7 @@
+ print(LOG $bpc->timeStamp, "unix socket() failed: $!\n");
+ exit(1);
+ }
+- my $sockFile = "$LogDir/BackupPC.sock";
++ my $sockFile = "/run/backuppc/BackupPC.sock";
+ unlink($sockFile);
+ if ( !bind(SERVER_UNIX, sockaddr_un($sockFile)) ) {
+ print(LOG $bpc->timeStamp, "unix bind() failed: $!\n");
+--- a/lib/BackupPC/Lib.pm
++++ b/lib/BackupPC/Lib.pm
+@@ -686,7 +686,7 @@
+ #
+ # First try the unix-domain socket
+ #
+- my $sockFile = "$bpc->{LogDir}/BackupPC.sock";
++ my $sockFile = "/run/backuppc/BackupPC.sock";
+ socket(*FH, PF_UNIX, SOCK_STREAM, 0) || return "unix socket: $!";
+ if ( !connect(*FH, sockaddr_un($sockFile)) ) {
+ my $err = "unix connect: $!";
diff --git a/community/backuppc/remove-deprecated-perl-defined-at.patch b/community/backuppc/remove-deprecated-perl-defined-at.patch
new file mode 100644
index 0000000000..471c767569
--- /dev/null
+++ b/community/backuppc/remove-deprecated-perl-defined-at.patch
@@ -0,0 +1,23 @@
+From 1261ba6d7a7ba0c973f25b8a63987360a639e16c Mon Sep 17 00:00:00 2001
+From: Alexander Moisseev <moiseev@mezonplus.ru>
+Date: Wed, 7 Jan 2015 15:11:49 +0300
+Subject: [PATCH] Browse.pm: - Remove deprecated defined(@array) perl5160delta:
+ http://perldoc.perl.org/perldiag.html#defined(@array)-is-deprecated
+
+---
+ lib/BackupPC/CGI/Browse.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/BackupPC/CGI/Browse.pm b/lib/BackupPC/CGI/Browse.pm
+index 7309955..fea400f 100644
+--- a/lib/BackupPC/CGI/Browse.pm
++++ b/lib/BackupPC/CGI/Browse.pm
+@@ -65,7 +65,7 @@ sub action
+ #
+ # default to the newest backup
+ #
+- if ( !defined($In{num}) && defined(@Backups) && @Backups > 0 ) {
++ if ( !defined($In{num}) && @Backups > 0 ) {
+ $i = @Backups - 1;
+ $num = $Backups[$i]{num};
+ }