aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-11-23 08:26:57 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-11-23 08:29:17 +0000
commit74ccecd6f26336615bde82c32dd4cbfffe48fdcb (patch)
tree973fbf8d9f8807c89b961bcd42cf3d2a75823649 /community
parentc72176ef6fa89529b5e4143ca691e2ddd4f493f4 (diff)
downloadaports-74ccecd6f26336615bde82c32dd4cbfffe48fdcb.tar.bz2
aports-74ccecd6f26336615bde82c32dd4cbfffe48fdcb.tar.xz
community/perl-type-tiny: new aport. In community because of per-test-postgresql dependency
Diffstat (limited to 'community')
-rw-r--r--community/perl-type-tiny/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/perl-type-tiny/APKBUILD b/community/perl-type-tiny/APKBUILD
new file mode 100644
index 0000000000..438794d6a5
--- /dev/null
+++ b/community/perl-type-tiny/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-type-tiny
+_pkgreal=Type-Tiny
+pkgver=1.000005
+pkgrel=0
+pkgdesc="tiny, yet Moo(se)-compatible type constraint"
+url="http://search.cpan.org/dist/Type-Tiny/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-exporter-tiny"
+cpanmakedepends=" perl-test-warnings"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TO/TOBYINK/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="2914b0e6b35c35f657d426fba29b4520 Type-Tiny-1.000005.tar.gz"
+sha256sums="42ed36c011825aa1e6995a4e8638621a1b2103a0970b15764ca3919368042365 Type-Tiny-1.000005.tar.gz"
+sha512sums="5817ee937384cccbea71fa69f8c2202d721c648a18eedf089529fbb956b2d050b889606e69c8bc3e1d94fb6f638b6cac01394b5534f17a8be6cdf82d69b965b6 Type-Tiny-1.000005.tar.gz"