aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-05-04 20:09:47 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-05-05 03:51:20 +0000
commit773ac3963e58529e49009e653bd09f82638368dc (patch)
tree922396376d85b4b636f0bbcdcf53bb07796c9cfc /community
parent39704ecda570c9466f670a0cd49d3c8bd433b7a8 (diff)
downloadaports-773ac3963e58529e49009e653bd09f82638368dc.tar.bz2
aports-773ac3963e58529e49009e653bd09f82638368dc.tar.xz
community/cadaver: allow neon-0.31
Cadaver checks what version of neon we have and complains if it's not in the list of supported versions. We already patch these checks to allow version 0.30, so lets do the same for 0.31. Fixes #11492
Diffstat (limited to 'community')
-rw-r--r--community/cadaver/APKBUILD2
-rw-r--r--community/cadaver/neon.patch12
2 files changed, 7 insertions, 7 deletions
diff --git a/community/cadaver/APKBUILD b/community/cadaver/APKBUILD
index decefb196a..7f8153a443 100644
--- a/community/cadaver/APKBUILD
+++ b/community/cadaver/APKBUILD
@@ -37,5 +37,5 @@ package() {
}
sha512sums="48fe0a266be0ca7239f325377e5e2a8dc57a5d60466c7160e36c060ad24c09a50727695b9fa931844b1e66e173ebbb838f390d6c60fd07b614bd3b636cd4dd41 cadaver-0.23.3.tar.gz
-dba57c355afda9552a890d53b32343f4532c441d7d654ea09b8ee6533a4d3a455a02327b393cf98228c4989622962d92b929a4c674919434b72ac285e5ced68c neon.patch
+6686be92a117f126ad9b9cad0e2de49ebfdd2d0ea79fd9ea8ce57cbffcbdee0a3d67cbfc52fa22ff9569ab83457a6b57994cc3c0f8099fdcf0893a55b683f5ed neon.patch
58982830b63c9bf4c27455e2d0403489bfdda82e4d236841c877d49c7501865edb3438cdddfb77ef7e525c4a5edb34083d3af69824f0ba2dc7d5c3f7f69b50e5 disable-nls.patch"
diff --git a/community/cadaver/neon.patch b/community/cadaver/neon.patch
index 10a581a574..e39348d777 100644
--- a/community/cadaver/neon.patch
+++ b/community/cadaver/neon.patch
@@ -6,7 +6,7 @@ $OpenBSD: patch-configure,v 1.4 2014/09/08 06:51:48 ajacoutot Exp $
if test "$ne_cv_lib_neon" = "yes"; then
ne_cv_lib_neonver=no
- for v in 27 28 29; do
-+ for v in 27 28 29 30; do
++ for v in 27 28 29 30 31; do
case $ne_libver in
0.$v.*) ne_cv_lib_neonver=yes ;;
esac
@@ -16,8 +16,8 @@ $OpenBSD: patch-configure,v 1.4 2014/09/08 06:51:48 ajacoutot Exp $
else
- { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&5
-$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&6;}
-+ { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&5
-+$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&6;}
++ { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&5
++$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&6;}
neon_got_library=no
fi
@@ -26,7 +26,7 @@ $OpenBSD: patch-configure,v 1.4 2014/09/08 06:51:48 ajacoutot Exp $
if test "$ne_cv_lib_neon" = "yes"; then
ne_cv_lib_neonver=no
- for v in 27 28 29; do
-+ for v in 27 28 29 30; do
++ for v in 27 28 29 30 31; do
case $ne_libver in
0.$v.*) ne_cv_lib_neonver=yes ;;
esac
@@ -36,8 +36,8 @@ $OpenBSD: patch-configure,v 1.4 2014/09/08 06:51:48 ajacoutot Exp $
else
- { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&5
-$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29" >&6;}
-+ { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&5
-+$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30" >&6;}
++ { $as_echo "$as_me:$LINENO: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&5
++$as_echo "$as_me: incompatible neon library version $ne_libver: wanted 0.27 28 29 30 31" >&6;}
neon_got_library=no
fi