aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-03 08:33:33 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-03 09:18:38 +0100
commit7ab88135d7ba679d91bed8d741ea45fc1f04580e (patch)
treedf6b408d7a5c5b4a120ba286e8af9ff7c33907c7 /community
parent6d937bccf3e4bc72325b54c57a9e6fc6a8f22f0d (diff)
downloadaports-7ab88135d7ba679d91bed8d741ea45fc1f04580e.tar.bz2
aports-7ab88135d7ba679d91bed8d741ea45fc1f04580e.tar.xz
community/xcb-util-errors: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/xcb-util-errors/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/xcb-util-errors/APKBUILD b/community/xcb-util-errors/APKBUILD
new file mode 100644
index 0000000000..517dc1ad60
--- /dev/null
+++ b/community/xcb-util-errors/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=xcb-util-errors
+pkgver=1.0
+pkgrel=0
+pkgdesc="XCB errors library"
+url="https://cgit.freedesktop.org/xcb/util-errors/"
+arch="all"
+license="MIT"
+makedepends="libxcb-dev m4"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.bz2::https://xcb.freedesktop.org/dist/xcb-util-errors-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="479b731b7056313955db9471d37416c4c9ab8c4574214fe20b3c0bcc1f57812fc343af6b0196814caaa6cc848dd120c70fab2f142902125cba63a8386d32179d xcb-util-errors-1.0.tar.bz2"